Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614287 - More information is necessary in 3.1. Compatibility
More information is necessary in 3.1. Compatibility
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Developer_Guide (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Don Domingo
ecs-bugs
: Documentation
Depends On: 642395 642397 642399
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 23:00 EDT by Masahiro Ito
Modified: 2011-12-06 21:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 21:31:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
draft build of RHEL6 Developer Guide (as of October 27, 1010) (2.34 MB, application/x-pdf)
2010-10-07 00:28 EDT, Don Domingo
no flags Details

  None (edit)
Description Masahiro Ito 2010-07-13 23:00:52 EDT
Description of problem:

In the section 3.1. Compatibility, the list of core libraries
doesn't seem user-friendly.

* Can you specify if they are filenames, or RPM package name.
  For example, at first glance, it's not clear if "libc" means only
  libc.so.6 or glibc RPM package. If you specify the form (either
  filename or RPM package name), you can define the range of core
  library clearly.

* Can you write in the format of full name? Some library names are shortened.
  For example, it seems that "libgtk-x11-2.0" or "libgtk-x11-2.0.so.0" are
  better than just "libgtk", because you can identify a library file easily
  and clearly.

* We need compat-* library information.
  When running application from older RHEL version, we need some
  compat-* libraries such as compat-glibc, compat-libstdc++, and so on.
  Can you add description like this?

    When you run RHEL 5 applications on RHEL 6, you might need:
       compat-glibc-2.5
       ....

    When you run RHEL 4 applications on RHEL 6, you might need:
       compat-...
       ...



Version-Release number of selected component (if applicable):

Developer Guide, published on http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6-Beta/ at June 2010

Revision 1.0 Thu Oct 08 2009

  
Actual results:

Expected results:

Additional info:
Comment 3 Benjamin Kosnik 2010-09-30 12:02:30 EDT
Hey. I re-did this based on the comments, added Package Names and added a RHEL 4 column. This draft is more coherent, I think. Please look at this and give more feedback.
Comment 4 Masahiro Ito 2010-10-07 00:12:58 EDT
Hi.

Thanks for letting me know that, but I can't see the up-to-date version with this site.

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Developer_Guide/index.html

Correct me if I'm wrong, but I guess the latest is available only in Red Hat. Or should I access with another URL for the latest one?
Comment 5 Don Domingo 2010-10-07 00:28:05 EDT
Created attachment 452033 [details]
draft build of RHEL6 Developer Guide (as of October 27, 1010)

Hi Masahiro,

sorry about that. attached is a draft build of the document in PDF format. it should contain all the changes mentioned by Benjamin.
Comment 6 Masahiro Ito 2010-10-14 06:56:02 EDT
Hi Don and Benjamin, 

I checked Developer Guides improved much and it covers my feedback, but can I ask one more thing?

This might be a technical question rather than feedback on the document. I found there is compat-glibc RPM in RHEL 6 DVD, but according to Table 3.2. Core Library Compatibility (ABI level is 2), you don't need compat-* library for glibc. They look like inconsistent with each other, so I'm a bit confused.

Can I confirm if we need compat-glibc for running applications built on RHEL 4/5?
Comment 7 Don Domingo 2010-11-22 21:11:41 EST
Benjamin, could you answer Masahiro's question?
for now, i'm setting this bug as MODIFIED.
Comment 9 Benjamin Kosnik 2011-03-24 06:11:03 EDT
I think this compat package is just for nss changes but I'm not entirely sure and in any case don't have access to my usual RHEL 6 vm at the moment to look at the rpm. I'll add Jakub and maybe he can clarify.

Note You need to log in before you can comment on or make changes to this bug.