Bug 614288 - RFE: Option to perform CPU pinning on a running VM, (aka #virsh vcpupin)
RFE: Option to perform CPU pinning on a running VM, (aka #virsh vcpupin)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: FutureFeature
Depends On:
Blocks: 655920
  Show dependency treegraph
 
Reported: 2010-07-13 23:10 EDT by dyuan
Modified: 2011-05-19 09:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:46:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dyuan 2010-07-13 23:10:35 EDT
Description of problem:

Assign the NUMA generated pinning to a running VM, which should not require a guest reboot to take effect as #virsh vcpupin behavior in libvirt.

And it should show the error just like 'error: vcpupin: Invalid vCPU number.' but not 'Some changes may require a guest reboot to take effect.' when I give a larger value than the num of physical cpus.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-07-13 23:37:20 EDT
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. It has been proposed for the next Red Hat Enterprise Linux
release.

**  If you would still like this feature request considered for
the current release, please ask your support representative to
file an exception on your behalf.  **
Comment 3 Daniel Berrange 2010-07-14 05:49:55 EDT
NB it doesn't make sense to refer to this as NUMA pinning, since NUMA pinning can only be done at startup. Once a VM is running, its memory has already been allocated from whatever NUMA node it started running on. You can change pinning of the virtual CPUs at runtime, but this will not affect NUMA placement of the guest's memory.
Comment 5 dyuan 2010-07-15 02:04:40 EDT
Version-Release number of selected component :
virt-manager-0.8.4-6.el6.
libvirt-0.8.1-15.el6.

This feature has been supported by libvirt for a long time, but never be supported by virt-manager. So, it's really a bug need to be fixed.
Comment 7 Cole Robinson 2011-01-13 14:27:06 EST
Upstream now:

http://hg.fedorahosted.org/hg/virt-manager/rev/076a25e83401
Comment 8 Cole Robinson 2011-01-14 17:19:39 EST
Fixed in virt-manager-0.8.6-1.el6
Comment 10 zhanghaiyan 2011-03-02 05:06:07 EST
Verified this bug PASS with virt-manager-0.8.6-2.el6.noarch

Could perfrom cpu pin for each vcpu at runtime via virt-manager
Comment 11 mliu 2011-04-18 01:33:27 EDT
Verified this bug PASS with virt-manager-0.8.6-3.el6.noarch
Comment 12 errata-xmlrpc 2011-05-19 09:46:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0637.html

Note You need to log in before you can comment on or make changes to this bug.