Bug 614300 - SNMP MIB does not define a notification-type
Summary: SNMP MIB does not define a notification-type
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Alerts   
(Show other bugs)
Version: 1.3.1
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: Heiko W. Rupp
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon30-bugs 648779
TreeView+ depends on / blocked
 
Reported: 2010-07-14 03:54 UTC by James Livingston
Modified: 2016-02-22 00:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 648779 (view as bug list)
Environment:
Last Closed: 2011-05-24 01:10:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modified MIB (3.11 KB, text/plain)
2010-07-14 03:54 UTC, James Livingston
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 966294 None None None Never

Internal Trackers: 966294

Description James Livingston 2010-07-14 03:54:47 UTC
Created attachment 431665 [details]
modified MIB

The MIB that JON ships with defines the contents of the SNMP alert notifications it sends. However, it doesn't define a NOTIFICATION-TYPE for the trap itself.

Attached is a modified version of the MIB which does define that. I don't know a whole lot about MIBs, but the customer said it worked for them with SNMPv2c - no idea if this version breaks v1 or v3.

Comment 2 Corey Welton 2010-09-28 12:38:31 UTC
heiko, how does this patch look?

Comment 3 Heiko W. Rupp 2010-10-18 13:35:16 UTC
Seems to be ok to me. Needs a new release date though :)

Comment 4 Heiko W. Rupp 2010-10-18 15:52:57 UTC
rev 414c79341bef50565825f85fc9201b205fb972b9 in master 
and
rev b57b9bf1f93bbd2d0059b2fd3f04ae4755d28ac9 in release-3.0.0

Comment 5 Corey Welton 2011-01-03 14:50:45 UTC
QA Verified, RHQ-mib.txt now contains 'NOTIFICATION-TYPE' reference:


    MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE, snmpModules, enterprises

Comment 6 Corey Welton 2011-05-24 01:10:30 UTC
Bookkeeping - closing bug - fixed in recent release.

Comment 7 Corey Welton 2011-05-24 01:10:45 UTC
Bookkeeping - closing bug - fixed in recent release.


Note You need to log in before you can comment on or make changes to this bug.