Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614309 - [abrt] crash in lmms-0.4.6-2.fc12: QMetaObject::removeGuard: Process /usr/bin/lmms was killed by signal 11 (SIGSEGV)
[abrt] crash in lmms-0.4.6-2.fc12: QMetaObject::removeGuard: Process /usr/bin...
Status: CLOSED DUPLICATE of bug 591591
Product: Fedora
Classification: Fedora
Component: lmms (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
abrt_hash:633300443f03d246c8e9119642d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 01:50 EDT by Stian Ellingsen
Modified: 2010-07-14 02:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 02:30:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (55.76 KB, text/plain)
2010-07-14 01:50 EDT, Stian Ellingsen
no flags Details

  None (edit)
Description Stian Ellingsen 2010-07-14 01:50:25 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: lmms
component: lmms
crash_function: QMetaObject::removeGuard
executable: /usr/bin/lmms
global_uuid: 633300443f03d246c8e9119642de5986aed7aecb
kernel: 2.6.32.14-127.fc12.i686.PAE
package: lmms-0.4.6-2.fc12
rating: 4
reason: Process /usr/bin/lmms was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

comment
-----
LMMS seems to crash randomly while playing instruments, especially when using the GUI keyboard.

Configuring LMMS to use ALSA with the default device (which routes to PulseAudio) seems to make the program crash faster than with ALSA hw:0,0 or direct PulseAudio.

How to reproduce
-----
1. On startup, open the instrument settings for the "Default preset" track.
2. Using the mouse, click and hold on a key on the keyboard that just appeared.
3. Drag the mouse fast left and right for a while, so that the instrument continuously plays different notes.
4. After a while, the UI freezes for a short moment and then disappears.
Comment 1 Stian Ellingsen 2010-07-14 01:50:28 EDT
Created attachment 431669 [details]
File: backtrace
Comment 2 Stian Ellingsen 2010-07-14 02:30:13 EDT
Looks like this is the same as bug 591591.

*** This bug has been marked as a duplicate of bug 591591 ***

Note You need to log in before you can comment on or make changes to this bug.