Bug 61433 - openmotif wrong version no.!
Summary: openmotif wrong version no.!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: openmotif (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-19 16:06 UTC by Sammy
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-19 20:05:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2002-03-19 16:06:04 UTC
After installing openmotif-2.2.1 rpm the version in /usr/X11R6/include/Xm/Xm.h
file is still 2.1.30. Is this correct? Because the latest source from openmotif.org
is 2.2.1.

Comment 1 Sammy 2002-03-19 20:05:31 UTC
Actually latest seems to be 2.2.3 from cvs and stable 2.2.2. BUT the
version number of libraries change from 2 to 3 so applications depending
on motif have to be recompiled. I just built the rpm for 2.2.3 and related
applications. All working ok.


Comment 2 Ngo Than 2002-03-22 12:37:00 UTC
It's fixed in openmotif-2.2.2-1.    
 
Notes: 
 
openmotif-2.2.2 is not binary compatible with openmotif-2.1. If you have any applictions    
built with 2.1, you have to rebuild them against 2.2.2 or just install the compat lib    
openmotif21. The new openmotif packages will be in next rawhide release or on  
ftp://people.redhat.com/than/rawhide

Comment 3 Sammy 2002-03-22 16:22:39 UTC
Thanks, I have recompiled and linked everything EXCEPT xdiff version 3.4.
For some reason linking with 2.2.2 via the line:
gcc -o xdiff xdiff3.4-LINUXintel.o -L/usr/X11R6/lib -lXm -lXmu -lXp -lXt -lX11
leads to an non-working executable, giving errors:
        ......
Warning: Cannot find callback list in XtAddCallback
Warning: Cannot find callback list in XtAddCallback
Warning:
    Name: verticalScroll
    Class: XmScrollBar
    The specified scrollbar value is greater than the maximum
    scrollbar value minus the scrollbar slider size.

A window pops up with a funny scrollbar and nothing inside. Menus do
not function. I know it is not an X problem because I can link it with
2.1.30 and it works.
FYI


Comment 4 Ngo Than 2002-03-23 07:18:41 UTC
It cannot work because openmotif-2.2.2 is binary inkompatible against openmotif-2.1. 
You cannot use object file xdiff3.4-LINUXintel.o to build xdiff with 2.2.2! 
 
This object file xdiff3.4-LINUXintel.o was built with old openmotif! 
 
To fix this problem you have to link it against 2.1.x.


Note You need to log in before you can comment on or make changes to this bug.