Bug 61434 - can't print locally or via network
can't print locally or via network
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-19 11:46 EST by don tuchband
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-20 02:49:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description don tuchband 2002-03-19 11:46:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4) Gecko/20011128
Netscape6/6.2.1

Description of problem:

I had a local printer and a network printer working fine on my Linux Redhat 7.2
box till
I started messing with Samba.  Now, when the system boots or if I run a checkpc
-f, I get 
error messages saying that "Starting lpd Warning owner/group of
/var/spool/lpd/gencom are 0/7
not 4/7 changing ownership to 0/7" and this continues for all the files
associated with the
printer - e.g. control.gencom.  Of course the printer does not work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create a printer
2.try and print
3.
	

Actual Results:  When the system boots or if I run a checkpc -f, I get 
error messages saying that "Starting lpd Warning owner/group of
/var/spool/lpd/gencom are 0/7
not 4/7 changing ownership to 0/7" and this continues for all the files
associated with the
printer - e.g. control.gencom.  Of course the printer does not work, using the
"test print" 
with KDE comes back with a message "There was an error trying to print the test
page" but if I 
and print a document from Kword, I get a more detailed message -
"Print error - Status Info - sending job 'root@mailboy + 838' to
gencom@localhost connecting
to localhost, attempt 1 connected to localhost requesting printer
gencom@localhost job root@mailboy
+ 838 transfer to gencon@localhost failed error "NONZERO RFC1179 ERROR Code from
server" with
ack 'ack-fail' sending str '^Bgencom" to gencom@localhost error msg printer
gencom, chdir to
/var/spool/lpd/gencom failed permission denied"




Expected Results:  job should print

Additional info:



When I change the directory permissions to 777 - the error messages go away, but
nothing prints.
I've reloaded the printconf-gui, printconf, & foomatic and downloaded
all of the lastest updates for these packages to no avail.

I'm lost/stumped and Redhat Tech support suggested I post this as a bug.  Your
help would be 
appreciated.

thanks,

don
Comment 1 Tim Waugh 2002-03-20 02:49:28 EST
Can you remember what it was you did with samba in the first place, so that I
can try to reproduce this problem?
Comment 2 don tuchband 2002-03-21 10:59:08 EST
Unfortunately, I'm not able to devote more than 20 minutes of uninterupted time
to this server - and since I've been unsuccessfully trying to resolve this
problem for the past two weeks - I finally decided to re-load the whole system.
 Recalling from some of my notes, I was updating the smb.conf file per some
directions in the "how To" and for some reason I changed the permissions on the
/tmp directory.  After that, if anyone but root logged on to the box - they
would get a blank gui screen and the printer problems started.  I nuked /tmp and
re-ran Xconfigurator and was able to get back the gui windows for users - but
the printers were still not working.  I've had a couple of Linux guru's look at
the box unsuccessfully - hence I finally decidede to just start over rather than
trying to figure out what I did.

I appreciate your looking into the problem,

don

Note You need to log in before you can comment on or make changes to this bug.