Bug 614351 - rpmbuild fails when building kernel from src.rpm.
rpmbuild fails when building kernel from src.rpm.
Status: CLOSED DUPLICATE of bug 613568
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 04:34 EDT by Nawaz
Modified: 2010-07-14 11:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 11:08:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbuild log (744.42 KB, text/x-log)
2010-07-14 04:34 EDT, Nawaz
no flags Details

  None (edit)
Description Nawaz 2010-07-14 04:34:58 EDT
Created attachment 431702 [details]
rpmbuild log

Description of problem:
rpm build fails when trying to build kernel from the source rpm.

Version-Release number of selected component (if applicable):
OS: RHEL 6.0 Beta 2.
Platform: x86_64
SRC RPM: kernel-2.6.32-37.el6.src.rpm

How reproducible:
When building kernel source rpm.

Steps to Reproduce:

1. Install the kernel source rpm on RHEL 6.0 Beta 2 
#rpm -ivh kernel-2.6.32-37.el6.src.rpm

2. Start rpm build
#rpmbuild -ba kernel.spec 2>&1 | tee build.log

 
Actual results:
1. rpmbuild fails with following errors:

crypto/signature/ksign-publickey.c:2:17: error: key.h: No such file or directory
crypto/signature/ksign-publickey.c: In function 'ksign_init':
crypto/signature/ksign-publickey.c:10: error: 'ksign_def_public_key' undeclared (first use in this function)
crypto/signature/ksign-publickey.c:10: error: (Each undeclared identifier is reported only once
crypto/signature/ksign-publickey.c:10: error: for each function it appears in.)
crypto/signature/ksign-publickey.c:11: error: 'ksign_def_public_key_size' undeclared (first use in this function)
make[2]: *** [crypto/signature/ksign-publickey.o] Error 1
make[1]: *** [crypto/signature] Error 2
make: *** [crypto] Error 2

Expected results:
rpmbuild should succeed with rpms created in the RPMS directory

Additional info:

Attached is the full build log.
Comment 2 Bill Nottingham 2010-07-14 11:08:50 EDT

*** This bug has been marked as a duplicate of bug 613568 ***

Note You need to log in before you can comment on or make changes to this bug.