Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 614377 - Windows 7 requires re-activation when migrated from RHEL5 to RHEL6
Windows 7 requires re-activation when migrated from RHEL5 to RHEL6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 06:20 EDT by Jes Sorensen
Modified: 2013-01-09 17:52 EST (History)
8 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.97.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 615057 (view as bug list)
Environment:
Last Closed: 2010-11-10 16:26:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2010-07-14 06:20:48 EDT
Description of problem:
Windows 7 requires re-activation when migrated from RHEL5 to RHEL6
due to change in SMBIOS data. 

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Install Windows 7 under RHEL5.5
2. Boot image under RHEL6 with -M rhel5.5.0 (or without -M)
3. Windows 7 then requires re-activation
  
Actual results:


Expected results:


Additional info:
Comment 2 Jes Sorensen 2010-07-14 06:48:00 EDT
Looks like this is fixable directly in qemu-kvm, without having to
make modifications to seabios, so changing component.
Comment 6 Jes Sorensen 2010-07-14 16:48:53 EDT
According to the discussion I had today with danpb, libvirt will set
-M per default, so yes.

Dan, can you please confirm?

Thanks,
Jes
Comment 7 Daniel Berrange 2010-07-15 05:36:47 EDT
The -M argument corresponds to the 'machine' attribute in libvirt XML

 <domain type='kvm'>
  <name>foo</name>
  ....
  <os>
    <type arch='i686' machine='pc-0.11'>hvm</type>
  </os>
  ...
 </domain>

If omitted, libvirt will pick a default machine type at time the guest is initially defined. On RHEL6 this will be the QEMU default machine type. On RHEL5 this is hardcoded as 'rhel-5.4.0'
Comment 9 Jes Sorensen 2010-07-23 03:50:14 EDT
Tested .97 here with a pre-installed win7 x64 image from RHEL6 and the image
stays activated as expected. Looks good to me.
Comment 10 Mike Cao 2010-07-23 07:04:53 EDT
Verified both for win7 32bit and win7 64 bit in qemu-kvm-0.12.1.2-2.97.el6.x86_64 ,Reproduced in qemu-kvm-0.12.1.2-2.96.el6.x86_64

Repeat the steps in comment #0,(note -M is a must in RHEL6 host)

Actual Results:

Windows 7 does NOT require re-activation.

The issue has already been fixed.
Comment 12 Mike Cao 2010-07-28 21:26:24 EDT
According to the comment #9 and comment #10, change issue's status to Verified.
Comment 13 releng-rhel@redhat.com 2010-11-10 16:26:33 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.