Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614470 - Module VERSION value breaks with use Archive::Tar $version
Module VERSION value breaks with use Archive::Tar $version
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: perl-Archive-Tar (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 10:44 EDT by Ben Walton
Modified: 2010-07-21 10:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 10:11:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Walton 2010-07-14 10:44:39 EDT
Description of problem:

When a program or module calls:
use Archive::Tar 1.29

A warning is printed similar to:
Argument "1.39_01" isn't numeric in subroutine entry

This is seemingly due to the way that version values are compared on module import.  It only happens when -w is passed to the intepreter or when 'use warnings;' is in effect.

Version-Release number of selected component (if applicable):
1.39.1-1

How reproducible:
Always


Steps to Reproduce:
Run this script:

#!/usr/bin/perl                                                                 

use warnings;
use Archive::Tar 1.29;                                                          

print "Hello world...";


Actual results:
Argument "1.39_01" isn't numeric in subroutine entry at test.pl line 4.
Hello world...


Expected results:
Hello world...

Additional info:

This isn't a critical issue, but it does cause our spamassassin sa-update cron job to generate mail at every run.

I've worked around it for now by adding:
$VERSION = eval $VERSION;

immediately after the $VERSION = "1.39_01";
line in Tar.pm.  This issue will only present on 'alpha' version numbering (ones containing the _XY).  An upstream fix adding the above line is likely appropriate as a general fix.
Comment 1 Marcela Mašláňová 2010-07-15 02:33:16 EDT
I believe there is policy that the same package can't be in EPEL and in RHEL. This package should be removed from EPEL if it's there. 

The bug was already fixed in RHEL #612879.
Comment 2 Marcela Mašláňová 2010-07-21 10:11:44 EDT
Mark as dead package in EPEL, because package is in RHEL repositories.

https://fedorahosted.org/rel-eng/ticket/3894

Note You need to log in before you can comment on or make changes to this bug.