Bug 614486 - kernel.core_pattern in /etc/sysctl.conf not getting set at boot
kernel.core_pattern in /etc/sysctl.conf not getting set at boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Denys Vlasenko
BaseOS QE - Apps
:
Depends On: 618602
Blocks: 627601
  Show dependency treegraph
 
Reported: 2010-07-14 11:11 EDT by Casey Dahlin
Modified: 2014-06-18 04:47 EDT (History)
13 users (show)

See Also:
Fixed In Version: abrt-1.1.15-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:41:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (13.65 KB, application/octet-stream)
2010-07-27 07:11 EDT, Denys Vlasenko
no flags Details
Updated patch (this one went to git) (14.41 KB, patch)
2011-01-06 10:00 EST, Denys Vlasenko
no flags Details | Diff

  None (edit)
Description Casey Dahlin 2010-07-14 11:11:38 EDT
The value in /etc/sysctl.conf for kernel.core_pattern is not being set in the system /proc filesystem on boot. If you manually run sysctl -p it does get set. In addition, there are errors messages being generated by default values in /etc/sysctl.conf:
error: "net.bridge.bridge-nf-call-ip6tables" is an unknown key
error: "net.bridge.bridge-nf-call-iptables" is an unknown key
error: "net.bridge.bridge-nf-call-arptables" is an unknown key
Comment 1 Bill Nottingham 2010-07-14 11:18:37 EDT
abrt is the only thing by default that sets core_pattern - assigning there. The *tables errors are unfortunate due to the order of network module loading, and can't be avoided; it's why all scripted invocations of it use '-e'.
Comment 4 RHEL Product and Program Management 2010-07-15 10:45:20 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 Denys Vlasenko 2010-07-27 07:06:59 EDT
Created bug 618602 - kernel's parameter length limit is too small to fix this bug.
Comment 7 Denys Vlasenko 2010-07-27 07:11:36 EDT
Created attachment 434661 [details]
Proposed patch
Comment 15 Denys Vlasenko 2010-11-22 09:27:43 EST
Since kernel-side fix (see bug 618602) is planned for inclusion in RHEL6 update,
we are ready to fix it on abrt side too.
Comment 16 Denys Vlasenko 2011-01-06 09:04:07 EST
Testing the fix for bug 614486 with kernel-2.6.32-83.el6.

I set /proc/sys/kernel/core_pattern to:

echo really_long_long_long_long_long_long_long_long_corename_s%s_c%c_p%p_u%u_g%g_t%t_h%h_e%e >/proc/sys/kernel/core_pattern

When abrt starts, it sets core_pattern to:

|/usr/libexec/abrt-hook-ccpp /var/spool/abrt %s %c %p %u %g %t %h %e 7265616c6c795f6c6f6e675f6c6f6e675f6c6f6e675f6c6f6e675f6c6f6e675f6c6f6e675f6c6f6e675f6c6f6e675f636f72656e616d655f7325735f6325635f7025705f7525755f6725675f7425745f6825685f652565

The long hex string is a hex-encoded "really_long_long_long_long_long_long_long_long_corename_s%s_c%c_p%p_u%u_g%g_t%t_h%h_e%e"

But only "|/usr/libexec/abrt-hook-ccpp /var/spool/abrt %s %c %p %u %g %t %h %e 7265616c6c795f6c6f6e675f6c6f6e675f6c6f6e675f6c6f6e675f6c6f" makes it (127 chars).

As a result, abrt-hook-ccpp saves coredump under truncated name "really_long_long_long_long_lo"

I'd say that for most real-world cases it will work, but raising the 128 char limit would be appreciated.
Comment 17 Denys Vlasenko 2011-01-06 09:47:26 EST
Fix is pushed to git, abrt_11x branch
Comment 18 Denys Vlasenko 2011-01-06 10:00:34 EST
Created attachment 472076 [details]
Updated patch (this one went to git)
Comment 25 errata-xmlrpc 2011-05-19 09:41:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0619.html

Note You need to log in before you can comment on or make changes to this bug.