Bug 614517 - Allow transfer of clipboard buffer
Allow transfer of clipboard buffer
Status: CLOSED CANTFIX
Product: Virtualization Tools
Classification: Community
Component: virt-viewer (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 12:12 EDT by caramba_bk
Modified: 2012-04-18 08:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 08:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description caramba_bk 2010-07-14 12:12:41 EDT
Often you want to transfer clipboard text between host and guest. It would be handy if this could be done with virt-viewer. For maximum safety, it could present a dialog prompt on demand, where you paste the text targeted for the guest. Once you've reviewed that the pasted text is actually what you intended to pass on, then you press OK and virt-viewer puts the text in the guest clipboard buffer.
Similarily in reverse, the dialog would display the guest buffer, and to put it in host buffer you would need to select and copy.
Comment 1 Daniel Berrange 2010-07-14 12:18:10 EDT
GTK-VNC / VNC already have support for cut+paste, but there's no support for this in QEMU's VNC server, hence it is pointless trying to enable it in virt-viewer currently.  We can't do anything further until QEMU supports this.
Comment 2 Daniel Berrange 2011-09-19 10:56:28 EDT
If the guest is configured to have SPICE graphics, and has a SPICE virtio serial channel configured, and the SPICE guest agent installed, cut+paste does now work with virt-viewer.

There's still nothing we can do about VNC yet
Comment 3 Daniel Berrange 2012-04-18 08:17:09 EDT
Realistically I don't think this will ever be done for VNC, so I'm going to close this

Note You need to log in before you can comment on or make changes to this bug.