Bug 614538 - firstboot does not start after manual install
Summary: firstboot does not start after manual install
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot
Version: rawhide
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Martin Gracik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F14Alpha, F14AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-07-14 17:29 UTC by James Laska
Modified: 2013-09-02 06:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-20 19:22:44 UTC


Attachments (Terms of Use)

Description James Laska 2010-07-14 17:29:25 UTC
Description of problem:

Firstboot doesn't start after a fresh manual install of rawhide.  It appears to be failing inside the XFrontEnd().start() method, but I'm not sure how to further debug around those signal methods.

Version-Release number of selected component (if applicable):
firstboot-1.110-1.fc13.x86_64

How reproducible:


Steps to Reproduce:
1. Perform a manual install of rawhide (http://serverbeach1.fedoraproject.org/pub/alt/stage/rawhide-testing/)
2. Perform an installation, accepting all defaults and using updates=http://jlaska.fedorapeople.org/updates/613623.img
3. Reboot into installed system
  
Actual results:

Firstboot never starts ... the user is taken directly to the GDM login

Expected results:

Firstboot configuration

Additional info:

 * Firstboot appears to be configured to start at runlevel 3 and 5

# chkconfig --list firstboot
firstboot      	0:off	1:off	2:off	3:on	4:off	5:on	6:off

 * There is no /etc/sysconfig/firstboot file that disables firstboot

# cat /etc/sysconfig/firstboot
cat: /etc/sysconfig/firstboot: No such file or directory

 * It emits the following traceback when attempting to start firstboot manually

# /etc/init.d/firstboot start
firstboot ERROR: X server failed to start
Traceback (most recent call last):
  File "/usr/sbin/firstboot", line 167, in <module>
    config.frontend.start()
  File "/usr/lib64/python2.6/site-packages/firstboot/xfrontend.py", line 87, in start
    raise RuntimeError, "X server failed to start"
RuntimeError: X server failed to start
                                                           [FAILED]

Comment 1 Martin Gracik 2010-07-15 14:09:29 UTC
Firstboot is not run because python-meh was changed, and the actual version of firstboot is not updated to these changes. I have a new version with the needed patch, but seems like I can't do the fedora builds. I need to get the permissions first, then I will make the new build, and it should work.

I tried it with the new version, and it worked OK.

Comment 2 Martin Gracik 2010-07-15 14:16:48 UTC
I couldn't reproduce the X server failed to start problem, so I guess that was some temporary problem.

Comment 3 Chris Lumens 2010-07-16 17:08:51 UTC
Martin - apply for the firstboot group in pkgdb and I'll approve you for it.

Comment 4 Adam Williamson 2010-07-16 17:13:04 UTC
Discussed at 2010/07/16 blocker meeting. We accept this as a blocker under the criterion "In most cases, the installed system must boot to a functional graphical environment (see Blocker_Bug_FAQ)": user account creation is done in firstboot, so if firstboot is skipped, you have no user accounts, and hence no way to log into a 'functional graphical environment' when you hit gdm (which won't let you log in as root).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 James Laska 2010-07-20 19:22:23 UTC
Confirmed this is fixed using firstboot-1.111-1.fc14


Note You need to log in before you can comment on or make changes to this bug.