Bug 614571 - libudev soname incorrect?
Summary: libudev soname incorrect?
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-14 19:04 UTC by Bill Nottingham
Modified: 2014-03-17 03:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 06:50:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2010-07-14 19:04:23 UTC
Description of problem:

Or, perhaps both. In any case, there's no versioned requires between udev and libudev, so you can currently get systemd + current udev + older libudev, and systemd immediately falls over with a symbol lookup error.

Version-Release number of selected component (if applicable):

systemd-3-3

How reproducible:

100%

Steps to Reproduce:
1. Install the minimum necessary requirements for systemd
2. Reboot
  
Actual results:

Kernel panic - attempted to kill init!

Comment 1 Lennart Poettering 2010-07-14 21:04:38 UTC
That looks like an ABI problem in udev, as well as a missing versioned dependency between udev and libudev. Reasssigning.

The >= 160 for udev we placed there for reasons unrelated to the ABI.


Note You need to log in before you can comment on or make changes to this bug.