Bug 614667 - Sync will fail if interrupted and say "ERROR: server.mount_point not set in the configuration file"
Sync will fail if interrupted and say "ERROR: server.mount_point not set in t...
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
540
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2010-07-14 18:49 EDT by Shawn Wells
Modified: 2014-07-04 09:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Wells 2010-07-14 18:49:07 EDT
Description of problem:
Attempted a satellite-sync then had to cancel out of it via control+c so that I could include a --email option.  When re-issued, I get:

ERROR: server.mount_point not set in the configuration file

Version-Release number of selected component (if applicable):
5.4

How reproducible:
Every time

Steps to Reproduce:
1. satellite-sync <channel>
2. control+c
3. satellite-sync --list-channel (or any argument)
4. you will see an error "ERROR: server.mount_point not set in the configuration file"
  
Actual results:
ERROR: server.mount_point not set in the configuration file

Expected results:
satellite-sync -<arg> should behave as normal

Additional info:

NORMAL BEHAVIOR
[root@ql sat]# satellite-sync --list-channels

18:57:39 Red Hat Network Satellite - live synchronization
18:57:39    url: https://satellite.rhn.redhat.com
18:57:39    debug/output level: 1
18:57:41    db:  rhnsat/<password>@rhnsat
18:57:41 18:57:41 Retrieving / parsing channel-families data
18:57:42 channel-families data complete
18:57:43 18:57:43 Retrieving / parsing channel data
18:58:13    p = previously imported/synced channel
18:58:13    . = channel not yet imported/synced
18:58:13    base-channels:
18:58:13       . redhat-linux-alpha-6.2                    1184
18:58:13       . redhat-linux-alpha-7.0                    1412
18:58:13       . redhat-linux-alpha-7.1                    1487
18:58:13       . redhat-linux-ee-i386-6.2                    13
18:58:13       . redhat-linux-i386-6.2                     1357
18:58:13       . redhat-linux-i386-7.0                     1615
18:58:13       . redhat-linux-i386-7.1                     2046
18:58:13       . redhat-linux-i386-7.2                     2338
..............
18:58:16     Import complete:
        Begin time: Tue Jul 13 18:57:39 2010
        End time:   Tue Jul 13 18:58:16 2010
        Elapsed:    0 hours, 0 minutes, 37 seconds


but now....

[root@ql ~]# satellite-sync --list-channel
08:26:33 ERROR: server.mount_point not set in the configuration file

[root@ql ~]# satellite-sync --list-channels
08:26:36 ERROR: server.mount_point not set in the configuration file

[root@ql ~]# satellite-sync --list-channels -m /var/satellite/
08:26:59 ERROR: server.mount_point not set in the configuration file

[root@ql ~]# satellite-sync --list-channels -m /var/satellite/x86lv/
08:27:05 ERROR: server.mount_point not set in the configuration file

[root@ql ~]# satellite-sync --list-channels -m=/var/satellite/x86lv/
ERROR: no such directory /root/=/var/satellite/x86lv


other config items:

[root@ql ~]# satellite-sync -p
CA_CHAIN             = /usr/share/rhn/RHNS-CA-CERT
DEFAULT_DB           = rhnsat/rhnsat@rhnsat
HTTP_PROXY           =
HTTP_PROXY_PASSWORD  =
HTTP_PROXY_USERNAME  =
ISS_CA_CHAIN         = /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
ISS_PARENT           =
RHN_PARENT           = satellite.rhn.redhat.com
TRACEBACK_MAIL       = me@myemail
abuse_check          = 0
allowed_iss_slaves   =
buffer_size          = 16384
cache_refresh_count_max = 5
cache_refresh_level  = 2
client_auth_timeout  = 3600.0
compress_headers     = 1
debug                = 1
disable_iss          = 0
disallow_user_creation = 1
disallowed_suffixes  =
enable_nvrea         = 0
enable_snapshots     = 1
encrypted_passwords  = 1
force_package_upload = 1
freeloader_throttle_end = 21
freeloader_throttle_start = 9
grace_no_throttle    = 0
jabber_server        = ql.rhnsatellite.XXXXXXX.com
join_rhn             = 0
kickstart_mount_point = /var/satellite
log_file             = /var/log/rhn/rhn_server_satellite.log
max_email_len        = 128
max_passwd_len       = 32
max_user_len         = 64
maximum_config_file_size = 131072
message_to_all       = /etc/rhn/message_to_all.txt
min_new_user_len     = 5
min_passwd_len       = 5
min_user_len         = 3
mount_point          = /var/satellite
nls_lang             = english.UTF8
pam_auth_service     =
pkg_list_dir         = /var/up2date/list
prepended_dir        = redhat
product_name         = RHN Satellite
proxy_auth_timeout   = 21600.0
quiet_mail           = 15
refer_to_www         = 0
repomd_cache_mount_point = /var/cache
repomd_path_prefix   = rhn/repodata
reset_base_channel   = 1
rhn_iss_metadata_handler = /SAT-DUMP-INTERNAL
rhn_metadata_handler = /SAT-DUMP
rhn_xmlrpc_handler   = /SAT
satellite            = 1
secret_key           = 794c582ca4c647a5bcdf0f95689aff39
send_eol_mail        = 0
send_message_to_all  = 0
session_lifetime     = 1800
session_secret_1     = ba8d426e8fe6ee1a55040faff99b97ca
session_secret_2     = 8c5f26485447da2ba514087fff09ee5b
session_secret_3     = 7e475ac092666e10e6e6c88af5b370aa
session_secret_4     = 1b8f4560993c0c75d8a054ff5b3c3867
sync_cache_dir       = /var/cache/rhn/
throttle_freeloaders = 0
throttle_grace_period = 168.0
use_taskomatic_repomd = 1
xml_dump_version     = 3.4
[root@ql ~]#
Comment 1 Miroslav Suchý 2010-07-15 04:34:36 EDT
Is is possible that your mount point is/var/satellite
 nfs share? And that it was offline at that moment? Are you able to do 
 ls -ld /var/satellite
 ls -l /var/satellite
at the same time you reproduce this bug?
Comment 2 Shawn Wells 2010-07-20 19:34:35 EDT
Hey Miroslav,  Sorry for the long delay.  Been onsite w/projects...

I duplicated the environment here at home and have the same issue.  /var/satellite is a local folder, no point point (NFS, LVM, or otherwise).

If satellite-sync encounters a control+c during the import (in my case, because we wanted to append a --email), then I receive the "server.mount_point not set in the configuration file" error.

This is fixed by completely rm -Rf'ing /var/satellite and re-running satellite-sync

Note You need to log in before you can comment on or make changes to this bug.