Bug 614690 - adminutil ICU RB generation can fail
adminutil ICU RB generation can fail
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.2.6
All Other
low Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
: VerifiedUpstream
Depends On:
Blocks: 434915
  Show dependency treegraph
 
Reported: 2010-07-14 21:11 EDT by Ulf Weltman
Modified: 2015-12-07 11:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:49:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch proposal (1.59 KB, patch)
2010-07-14 21:11 EDT, Ulf Weltman
no flags Details | Diff
patch for admin server's genrb_wrapper.sh (486 bytes, patch)
2010-07-19 18:41 EDT, Ulf Weltman
no flags Details | Diff

  None (edit)
Description Ulf Weltman 2010-07-14 21:11:01 EDT
genrb fails on HP-UX because genrb_wrapper.sh invokes it like:
LD_LIBRARY_PATH=/wherever exec genrb
POSIX shell on HP-UX doesn't pass the environment variable to the exec'd process.  Can the exec just be removed?

Another thing I noticed which isn't platform specific is that it tries to invoke the genrb_wrapper.sh script while assuming cwd is the build root.  For example, if we're in adminutil/HP-UXB.11.23_ia64_64_OPT.OBJ it tries to invoke lib/libadminutil/genrb_wrapper.sh when it should be ../lib/libadminutil/genrb_wrapper.sh.
Comment 1 Ulf Weltman 2010-07-14 21:11:53 EDT
Created attachment 431957 [details]
patch proposal
Comment 2 Rich Megginson 2010-07-15 11:22:05 EDT
To ssh://git.fedorahosted.org/git/389/adminutil.git
   e07acba..6a23fa9  master -> master
commit 6a23fa916a7761a6e48f3b79d07f8208cf10f4bf
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Thu Jul 15 09:21:41 2010 -0600
Comment 4 Ulf Weltman 2010-07-19 18:41:33 EDT
Created attachment 433025 [details]
patch for admin server's genrb_wrapper.sh

Please also make the change to remove exec from adminserver's genrb_wrapper.sh script.
Comment 5 Nathan Kinder 2011-03-08 14:18:33 EST
Checked in admin patch to master.

Counting objects: 7, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 492 bytes, done.
Total 4 (delta 3), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/admin.git
   f7554f2..9866d75  master -> master

Note You need to log in before you can comment on or make changes to this bug.