Bug 614697 - mcastport error in <totem...> argument in cluster.conf
mcastport error in <totem...> argument in cluster.conf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cluster (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Fabio Massimo Di Nitto
Fedora Extras Quality Assurance
:
: 613880 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 22:52 EDT by digimer
Modified: 2010-07-15 10:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 03:27:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Current cluster.conf file that fails to load. (3.79 KB, application/octet-stream)
2010-07-14 22:52 EDT, digimer
no flags Details

  None (edit)
Description digimer 2010-07-14 22:52:26 EDT
Created attachment 431961 [details]
Current cluster.conf file that fails to load.

Description of problem:

Adding this to cluster.conf causes cman to fail on load.

-------------------------------------------------------------------
<cluster name="an-cluster" config_version="8">
    <totem rpp_mode="passive">
        <interface ringnumber="0" bindnetaddr="10.0.1.0" mcastaddr="226.94.1.1" mcastport="5405"/>
    </totem>
</cluster>

It generates the error:

Starting cluster:
   Checking Network Manager...                             [  OK  ]
   Global setup...                                         [  OK  ]
   Loading kernel modules...                               [  OK  ]
   Mounting configfs...                                    [  OK  ]
   Starting cman... corosync died: Error, reason code is 8
                                                           [FAILED]
-------------------------------------------------------------------

In the logs, this error is shown:

-------------------------------------------------------------------
Jul 14 00:00:46 an-node01 corosync[2227]:   [MAIN  ] Corosync Cluster Engine ('1.2.3'): started and ready to provide service.
Jul 14 00:00:46 an-node01 corosync[2227]:   [MAIN  ] Corosync built-in features: nss rdma
Jul 14 00:00:46 an-node01 corosync[2227]:   [MAIN  ] Successfully read config from /etc/cluster/cluster.conf
Jul 14 00:00:46 an-node01 corosync[2227]:   [MAIN  ] Successfully parsed cman config
Jul 14 00:00:46 an-node01 corosync[2227]:   [MAIN  ] Successfully configured openais services to load
Jul 14 00:00:46 an-node01 corosync[2227]:   [MAIN  ] parse error in config: No multicast port specified
Jul 14 00:00:46 an-node01 corosync[2227]:   [MAIN  ] Corosync Cluster Engine exiting with status 8 at main.c:1430.
-------------------------------------------------------------------

If I remove the <totem ...> section, cman will start and the following is shown in 'corosync-objdb | grep totem':

-------------------------------------------------------------------
totem.interface.ringnumber=0
totem.interface.bindnetaddr=10.0.1.71
totem.interface.mcastaddr=239.192.122.47
totem.interface.mcastport=5405
-------------------------------------------------------------------

This leads me to believe that the internals are ok, as mcastport is set. I would suspect then that the issue is with the loader and/or adapter.

Version-Release number of selected component (if applicable):

cman-3.0.12-2.fc13.x86_64
corosync-1.2.3-1.fc13.x86_64

How reproducible:

Seems to be 100%

Steps to Reproduce:
1. Add <totem ...> section above.
2. Start cman
3.
  
Actual results:

cman fails to start.

Expected results:

cman starts with specified totem ring(s) parameters.

Additional info:
Comment 1 Christine Caulfield 2010-07-15 03:27:24 EDT
chaging mcastport is not supported when running in a cman managed cluster.

The correct way to add interfaces and change the multicast address is to use the cman directives, not corosync ones.

To change the multicast address use 

<cman> <multicast addr="address"/> </cman>

To add interfaces (and this is unsupported) use the procedure document here:

http://sources.redhat.com/cluster/wiki/MultiHome
Comment 2 Lon Hohberger 2010-07-15 10:29:28 EDT
*** Bug 613880 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.