Bug 614752 - SELinux is preventing abrtd "unlink" access on /var/run/abrt.socket.
SELinux is preventing abrtd "unlink" access on /var/run/abrt.socket.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Walsh
Milos Malik
setroubleshoot_trace_hash:974ffd3e551...
:
: 614751 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 03:09 EDT by Michal Nowak
Modified: 2013-03-07 21:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 10:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2010-07-15 03:09:55 EDT
Summary:

SELinux is preventing abrtd "unlink" access on /var/run/abrt.socket.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:var_run_t:s0
Target Objects                /var/run/abrt.socket [ sock_file ]
Source                        abrtd
Source Path                   abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-31.el6
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32-44.el6.x86_64 #1 SMP Wed Jul 7 15:47:50 EDT
                              2010 x86_64 x86_64
Alert Count                   3
First Seen                    Fri 09 Jul 2010 03:22:15 PM CEST
Last Seen                     Thu 15 Jul 2010 08:59:41 AM CEST
Local ID                      4c7aa9dc-67b4-4d08-a1f3-e0e372092eef
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1279177181.434:32660): avc:  denied  { unlink } for  pid=31591 comm="abrtd" name="abrt.socket" dev=dm-0 ino=524541 scontext=unconfined_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=sock_file



Hash String generated from  catchall,abrtd,abrt_t,var_run_t,sock_file,unlink
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t var_run_t:sock_file unlink;
Comment 2 Milos Malik 2010-07-15 04:40:39 EDT
The abrt.socket file on your machine is mislabelled.

# matchpathcon  /var/run/abrt.socket
/var/run/abrt.socket	system_u:object_r:abrt_var_run_t:s0
Comment 3 Daniel Walsh 2010-07-15 08:47:21 EDT
Any idea how this happened?  Did you run abrt outside of the service script?
Comment 4 Daniel Walsh 2010-07-15 08:49:06 EDT
*** Bug 614751 has been marked as a duplicate of this bug. ***
Comment 5 Michal Nowak 2010-07-15 09:29:21 EDT
Yes. When testing the daemon I have to stop the service and start daemon this way manually, e.g. `abrtd -dvvv`.
Comment 6 Daniel Walsh 2010-07-15 10:21:14 EDT
Well that will run it under a different context, causing these AVC messages.  If you run within an initrc_exec_t labeled shell it will work.  Or run

runcon -t initrc_t -- bash -c abrtd -dvvv

The right transitions will happen.
Comment 7 RHEL Product and Program Management 2010-07-15 11:10:46 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Note You need to log in before you can comment on or make changes to this bug.