Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614758 - lvconvert --repair does not deal with transient errors
lvconvert --repair does not deal with transient errors
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.5
All Linux
high Severity high
: rc
: ---
Assigned To: Petr Rockai
Corey Marthaler
: ZStream
Depends On: 568138
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 03:17 EDT by RHEL Product and Program Management
Modified: 2013-01-10 22:07 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 05:34:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2010-07-15 03:17:43 EDT
This bug has been copied from bug #568138 and has been proposed
to be backported to 5.5 z-stream (EUS).
Comment 4 Petr Rockai 2010-07-15 04:39:19 EDT
1) I don't see how this is a regression. I have removed the spurious keyword.
2) Why zstream? The changes related to this bug have been discussed for zstream before and found too intrusive. Please reconsider.
Comment 6 RHEL Product and Program Management 2010-07-16 05:34:55 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 7 Takahiro Yasui 2010-07-16 21:17:28 EDT
(In reply to comment #4)
> 1) I don't see how this is a regression. I have removed the spurious keyword.

See bug 568138 comment #16

---
In 5.4, transient/medium errors aren't recovered, but systems can keep running
with a device marked failed if there is still valid mirror legs. It is an
expected behavior for mirroring.

On the other hand, in 5.5 beta1, application which issued I/Os is stuck and
system can't keep running. This happens because dm-raid1 was updated so that
I/Os are blocked until a failure is recovered.
---

If dmeventd can't handle this kind of error, application will hangup forever.
That's the reason why I think it is regression from RHEL5.4.

> 2) Why zstream? The changes related to this bug have been discussed for zstream
> before and found too intrusive. Please reconsider.    

Then, please consider to fix this in RHEL5.6.

Note You need to log in before you can comment on or make changes to this bug.