Bug 614770 - The uname binary is missing from the stage2 image install.img
The uname binary is missing from the stage2 image install.img
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: David Cantrell
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 04:32 EDT by taipan_yh
Modified: 2010-11-10 14:50 EST (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.59-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:50:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description taipan_yh 2010-07-15 04:32:01 EDT
Description of problem:
The uname binary is missing from the stage2 image install.img

Version-Release number of selected component (if applicable):
RHEL6.0-20100622.1-Server-i386, the beta2 release

How reproducible:
easy

Steps to Reproduce:
just mount install.img that is present in the RHEL6 iso in images/install.img and search for uname.
  
Actual results:
The uname binary is missing from the stage2 image install.img

Expected results:
uname should be included in install.img

Additional info:
In case this is not a bug, should i expect uname not to be included in the stage2 image for the official release?
Comment 2 RHEL Product and Program Management 2010-07-15 10:25:47 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 taipan_yh 2010-07-15 12:34:05 EDT
Not really a blocker, just an annoying inconvenience. Fixing this is trivial - just add uname to install.img - and there is no reason why uname shouldn't be part of the stage2 image.
Comment 6 Alexander Todorov 2010-07-23 06:12:24 EDT
uname binary is present and works in 0722.0 tree.  Moving to VERIFIED.
Comment 7 releng-rhel@redhat.com 2010-11-10 14:50:58 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.