Bug 6148 - fdisk -l syntax broken
fdisk -l syntax broken
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-20 13:00 EDT by Joshua Jensen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 18:40:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 1999-10-20 13:00:56 EDT
"fdisk -l" by itself no longer works.  The man page is now
incorrect.  Now required is a device: "fdisk -l /dev/xyz".
While this isn't the end of the world, this breaks many
scripts all over the place (including mkkickstart).  Can you
please change this?  It is very convenient to get a listing
of all partitions on all drives.
Comment 1 David Lawrence 1999-10-20 13:26:59 EDT
Tha man page is actually correct because the line

fdisk -l [-u] device

means the device specification is no longer optional when using the -l
switch where as the -u is. In the older fdisk manpage it was formatted
as

fdisk -l [-u] [device]

but anyway, i agree that the old way fdisk worked was better and I am
assigning this report to the proper developer since fdisk -l does in
fact now require a device name list.
Comment 2 onigif 2000-01-15 15:13:59 EST
I need to use "fdisk -l" so, i have change it whit older version.
Can you in future reinsert this function?
thanks.
Comment 3 Cristian Gafton 2000-02-17 18:40:59 EST
fdisk -l used to cause probing for all types of storage devices (not only fixed
hard disks), with results that were not always obvious (ie an invalid jaz drive,
or trying to autoload some module to access a certain medium, etc)

for fdisk -l you are better off using /proc/paritions (and going after fdisk -l
<device> if you need more info)

Note You need to log in before you can comment on or make changes to this bug.