Bug 614812 - Autopartitioning clears immutable partitions on 2nd retry
Autopartitioning clears immutable partitions on 2nd retry
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
: 608902 (view as bug list)
Depends On: 593642
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 06:22 EDT by Alexander Todorov
Modified: 2011-05-19 08:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-13.21.84-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 593642
Environment:
Last Closed: 2011-05-19 08:31:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage.log from 2nd install (109.67 KB, text/plain)
2010-07-15 06:32 EDT, Alexander Todorov
no flags Details
tarball with all logs (37.63 KB, application/x-gzip)
2010-07-15 06:33 EDT, Alexander Todorov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0530 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-05-18 13:44:52 EDT

  None (edit)
Description Alexander Todorov 2010-07-15 06:22:47 EDT
+++ This bug was initially created as a clone of Bug #593642 +++

When an inconsistent lvm vg is found the user can choose to ignore the involved pvs (often partitions), these then get added to anaconda's immutableDevices list, yet autopartitioning with a clearpart type of linux or all will still remove the
involved partitions as shouldClear() does not honour the immutableDevices list.

--- Additional comment from pm-rhel@redhat.com on 2010-05-19 14:55:06 EEST ---

This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

--- Additional comment from hdegoede@redhat.com on 2010-05-19 18:09:46 EEST ---

Note to QA. To reproduce this, do a default autopart install on 2 disks, then remove one disk (easiest with a vm), and start a new interactive install when prompted about the imcomplete volgroup, choose ignore, then choose clear linux partitions, check review partition layout and continue. You should get a complaint that there is not enough free space, instead the pv of the broken vg will get re-used, which should not happen as it should be ignored.

Can we get a qa-ack for this please ?

--- Additional comment from hdegoede@redhat.com on 2010-05-20 12:53:45 EEST ---

Fixed in anaconda-13.21.44-1, moving to modified.

--- Additional comment from releng-rhel@redhat.com on 2010-05-21 15:19:19 EEST ---

anaconda-13.21.44-1.el6 included in compose 'RHEL6.0-20100520.0' and is marked as having fixed this bug.
Moving to ON_QA.

--- Additional comment from atodorov@redhat.com on 2010-07-14 16:14:09 EEST ---

(In reply to comment #2)
> Note to QA. To reproduce this, do a default autopart install on 2 disks, then
> remove one disk (easiest with a vm), and start a new interactive install when
> prompted about the imcomplete volgroup, choose ignore, then choose clear linux
> partitions, check review partition layout and continue. You should get a
> complaint that there is not enough free space, instead the pv of the broken vg
> will get re-used, which should not happen as it should be ignored.
> 

Hans,
with 0707.4 tree I followed your steps to reproduce leaving the second disk for the second install. I got the error dialog telling me there wasn't enough free space. /so far bug is fixed/

After clicking OK there was a windows such as "re-scanning disks" or similar and then I just hit Next without changing previous settings. The second time anaconda didn't complain about missing space but happily removed my previous partitioning ( a single PV in this case) and created default partitioning (/boot, PV and / and swap in LVs). 

Is the behavior in the second retry expected or something related to this bug ?

--- Additional comment from hdegoede@redhat.com on 2010-07-14 20:59:12 EEST ---

Hi,

(In reply to comment #5)
> Hans,
> with 0707.4 tree I followed your steps to reproduce leaving the second disk for
> the second install. I got the error dialog telling me there wasn't enough free
> space. /so far bug is fixed/
> 
> After clicking OK there was a windows such as "re-scanning disks" or similar
> and then I just hit Next without changing previous settings. The second time
> anaconda didn't complain about missing space but happily removed my previous
> partitioning ( a single PV in this case) and created default partitioning
> (/boot, PV and / and swap in LVs). 
> 
> Is the behavior in the second retry expected or something related to this bug ?    

Sounds like you've found a new (related) bug, can you please reproduce and file a new bug for this with logs attached ?

Thanks,

Hans
Comment 1 Alexander Todorov 2010-07-15 06:26:24 EDT
To reproduce:

1) Start a KVM domU with 2 disks and use default partitioning (LVM)
2) Remove disk 1 (vda, which has /boot and a PV) and start a second install with only disk 2.
3) Anaconda will tell you that LVM metadata was incomplete and ask if you want to re-initialize the disk. Click Ignore.
4) Select "Remove All Linux partitions" and "review partitioning layout" in the UI
5) Press Next. Anaconda will tell you that there wasn't enough free disk space. 
6) After clicking OK on the error message anaconda will scan the disks again. The UI selection from 4) will be intact. Press Next again. 
7) Anaconda will wipe the previous PV on the disk and create default layout: /boot and a PV and everything else inside a VG.
Comment 2 Alexander Todorov 2010-07-15 06:32:45 EDT
Created attachment 432023 [details]
storage.log from 2nd install
Comment 3 Alexander Todorov 2010-07-15 06:33:07 EDT
Created attachment 432024 [details]
tarball with all logs
Comment 7 RHEL Product and Program Management 2010-11-15 19:49:37 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 9 David Lehman 2011-01-24 16:24:46 EST
*** Bug 608902 has been marked as a duplicate of this bug. ***
Comment 10 Pavel Holica 2011-02-18 04:41:51 EST
reproduced bug on RHEL6.0 GA x86_64 Server
verified fix on RHEL6.1-20110210.1 x86_64 Server
tested as described in comment 1
Comment 11 errata-xmlrpc 2011-05-19 08:31:13 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0530.html

Note You need to log in before you can comment on or make changes to this bug.