Bug 614819 - Glyph «8»
Glyph «8»
Status: CLOSED DUPLICATE of bug 591556
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 06:46 EDT by Misha Shnurapet
Modified: 2010-07-15 07:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 07:21:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
8.png (2.14 KB, image/png)
2010-07-15 06:46 EDT, Misha Shnurapet
no flags Details
interior.png (79.93 KB, image/png)
2010-07-15 06:47 EDT, Misha Shnurapet
no flags Details

  None (edit)
Description Misha Shnurapet 2010-07-15 06:46:34 EDT
Created attachment 432029 [details]
8.png

Description of problem:
The number «8» glyph has some kind of a wart on its face.

See the attached file 8.png

freetype-freeworld-2.3.11-1.fc12.x86_64
freetype-debuginfo-2.3.11-3.fc12.x86_64
freetype-freeworld-debuginfo-2.3.11-1.fc12.x86_64
freetype-2.3.11-3.fc12.x86_64

liberation-sans-fonts-1.05.1.20090721-2.fc12.noarch
liberation-mono-fonts-1.05.1.20090721-2.fc12.noarch
liberation-fonts-common-1.05.1.20090721-2.fc12.noarch
liberation-serif-fonts-1.05.1.20090721-2.fc12.noarch

$ ls /etc/yum.repos.d/
fedora-rawhide.repo          rpmfusion-free.repo
fedora.repo                  rpmfusion-free-updates.repo
fedora-updates.repo          rpmfusion-free-updates-testing.repo
fedora-updates-testing.repo  rpmfusion-nonfree-rawhide.repo
infinality.repo              rpmfusion-nonfree.repo
remi.repo                    rpmfusion-nonfree-updates.repo
rpmfusion-free-rawhide.repo  rpmfusion-nonfree-updates-testing.repo

$ cat /etc/yum.repos.d/infinality.repo 
[infinality]
name=Infinality
baseurl=http://www.infinality.net/fedora/linux/$releasever/$basearch/
enabled=1
gpgcheck=0

[infinality-noarch]
name=Infinality - noarch
baseurl=http://www.infinality.net/fedora/linux/$releasever/noarch/
enabled=1
gpgcheck=0

$ cat ~/.fonts.conf 
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
    <match target="font" >
        <edit mode="assign" name="rgba" >
            <const>rgb</const>
        </edit>
        <edit mode="assign" name="hinting" >
            <bool>true</bool>
        </edit>
        <edit mode="assign" name="autohint" >
            <bool>true</bool>
        </edit>
        <edit mode="assign" name="antialias" >
            <bool>true</bool>
        </edit>
        <edit mode="assign" name="hintstyle" >
            <const>hintfull</const>
        </edit>
        <edit name="lcdfilter" mode="assign">
            <const>lcddefault</const>
        </edit>
    </match>
</fontconfig>

Size 8. I set 98 dpi for proper kerning on my monitor.
Comment 1 Misha Shnurapet 2010-07-15 06:47:45 EDT
Created attachment 432031 [details]
interior.png

This is how it looks like in interface.
Comment 2 Pravin Satpute 2010-07-15 07:21:37 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=591556 these both looks me the same issue something wrong with hinting

so closing this as a duplicate of above one, it will get fixed there

*** This bug has been marked as a duplicate of bug 591556 ***

Note You need to log in before you can comment on or make changes to this bug.