Bug 614824 - Evince doesn't highlight properly
Evince doesn't highlight properly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: poppler (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Marek Kašík
Desktop QE
:
Depends On:
Blocks: 1271696
  Show dependency treegraph
 
Reported: 2010-07-15 06:51 EDT by Lubos Kocman
Modified: 2016-05-10 16:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: poppler-0.12.4-7.el6
Doc Type: Bug Fix
Doc Text:
Cause: Highlighting document by clicking and dragging mouse over multiple lines in direction "From bottom to top". Consequence: Parts of lines that are being highlighted disappear. Fix: Selection of TextLine doesn't take y-coordinates of the selection rectangle into account once we decide to select the line. Result: The bug doesn’t present anymore.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:48:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
problematic document (90.27 KB, application/pdf)
2010-07-15 06:51 EDT, Lubos Kocman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0799 normal SHIPPED_LIVE evince and poppler bug fix update 2016-05-10 18:37:49 EDT

  None (edit)
Description Lubos Kocman 2010-07-15 06:51:50 EDT
Created attachment 432033 [details]
problematic document

Description of problem:

If you'll open an PDF file containing some specific Czech characters like š,ě,č,ř,ž and you'll highlight the text, then you'll see that some specific characters are not visible anymore.

Also if you'll highlight document by clicking and draging mouse over multiple lines in direction "Frmm bottom to top" some part of lines will disappear while being highlighted.

Version-Release number of selected component (if applicable):

evince-2.28.2-13.el6.x86_64
poppler-0.12.4-3.el6.x86_6

How reproducible:


Steps to Reproduce:
1. Open attached pdf document
2. highlight first paragraph multiple times in a different direction
3. highlight multiple paragraph by clicking + draging from bottom to top
  
Actual results:

some characters and part of lines are invisible while being higlighted

Expected results:

every character should be visible as while not being highlighted


Additional info:
Comment 2 RHEL Product and Program Management 2010-07-15 10:27:24 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 RHEL Product and Program Management 2011-01-07 10:47:00 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 Lubos Kocman 2011-05-03 05:53:03 EDT
Is anybody going to do something about this? I have found also another issue in highlighting. So seems like that this topic is very problematic.
Comment 7 RHEL Product and Program Management 2011-07-05 20:21:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 9 Suzanne Yeghiayan 2012-02-14 18:00:35 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 10 Marek Kašík 2014-12-10 08:43:00 EST
These are actually 2 bugs.

The first one is that selection of TextLine shouldn't take y coordinates of the selection rectangle into account once we decide to select the line. We can fix this since the patch is quite simple (see http://cgit.freedesktop.org/poppler/poppler/commit/?id=5056e33e01ce0f7db1a5401b7b38d30e84eedf69).

The second one is that each TextWord has only one font set which means that if a TextWord contains a character which needs different font then the character is drawn by wrong font which usually doesn't have a glyph for the character resulting in empty space.
This is not possible to fix without API change since the API of TextWord is public (see http://cgit.freedesktop.org/poppler/poppler/commit/?id=f3a1b765bd6a58d327a80feedbe30e1c0792076e).

I'm giving devel_ack+ to the first problem. We can not fix the second one because of the API change.
Comment 17 errata-xmlrpc 2016-05-10 16:48:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0799.html

Note You need to log in before you can comment on or make changes to this bug.