Bug 614841 - Some of the webservice functions fail with UTF8 strings
Summary: Some of the webservice functions fail with UTF8 strings
Status: CLOSED NOTABUG
Alias: None
Product: Bugzilla
Classification: Community
Component: WebService   
(Show other bugs)
Version: 3.6
Hardware: All
OS: Linux
high
medium vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: RHBZ36UpgradeTracker
TreeView+ depends on / blocked
 
Reported: 2010-07-15 11:39 UTC by Noura El hawary
Modified: 2013-06-24 01:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 12:30:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noura El hawary 2010-07-15 11:39:39 UTC
some of the webservice API functions fails with the UTF8 strings, from running the test t/443_webservice_ext_utf8_data.pl, those are the functions that currently fail:

bugzilla.getBugSimple
Bug.get
bugzilla.runQuery
Bug.search
Bug.update

the rest of the webservice functions that handle UTF8 work fine.

regards,
Noura

Comment 1 Noura El hawary 2010-07-29 12:30:40 UTC
I tried testing those functions against partner-bugzilla and they all passed with UTF-8 strings, so seems that the UTF-8 problem is only on my machine because of the SOAP::Lite module installed, I had this similar problem when we were testing BZ3.2 and I remember that David installed a different version of SOAP::Lite on the testing and the life servers of bugzilla and the UTF-8 worked after, and seems that he got the right module installed now in partner-bugzilla.

Closing the bug.

Noura

Comment 2 Kevin Baker 2010-07-29 19:58:16 UTC
thank god for testing.

Are we carrying a patched version of SOAP::Lite? Or is this version that works an upstream version?

Comment 3 David Lawrence 2010-07-29 20:22:58 UTC
(In reply to comment #2)
> thank god for testing.
> 
> Are we carrying a patched version of SOAP::Lite? Or is this version that works
> an upstream version?    

Newer version of SOAP::Lite that what is shipped in RHEL5.

Dave


Note You need to log in before you can comment on or make changes to this bug.