Bug 614867 - Invisible pre-edit buffer when using m17n Wijesekera keyboard layout
Summary: Invisible pre-edit buffer when using m17n Wijesekera keyboard layout
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-m17n   
(Show other bugs)
Version: 13
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-15 12:38 UTC by Harshula Jayasuriya
Modified: 2010-08-13 21:31 UTC (History)
3 users (show)

Fixed In Version: ibus-m17n-1.3.0-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 21:08:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
corresponding output: නෝෙනා්නෝනෝෙනා් (5.95 KB, application/octet-stream)
2010-07-26 05:50 UTC, Harshula Jayasuriya
no flags Details

Description Harshula Jayasuriya 2010-07-15 12:38:13 UTC
Description of problem:

A Wijesekera keyboard layout user created a video of this problem on Fedora 13. It can not be reproduced in gedit but can be reproduced in open office and evolution. My guess is these applications don't display the pre-edit buffer. Whereas, gedit does display the pre-edit buffer. What happens is that you only see the output of nth key press after the (n+1) key press has occurred.

Version-Release number of selected component (if applicable):
ibus-chewing-1.3.4.20100608-1.fc13.i686
ibus-pinyin-db-android-1.3.8-1.fc13.noarch
ibus-anthy-1.2.1-1.fc13.i686
ibus-libs-1.3.6-1.fc13.i686
ibus-pinyin-1.3.8-1.fc13.i686
ibus-m17n-1.3.0-1.fc13.i686
ibus-1.3.6-1.fc13.i686
ibus-hangul-1.3.0.20100329-1.fc13.i686
ibus-gtk-1.3.6-1.fc13.i686
ibus-rawcode-1.3.1.20100707-1.fc13.i686

How reproducible:
Always

Steps to Reproduce:
1. open oowriter
2. select the Wijesekera keyboard layout in IBus
3. type the key sequence: iupap,h'

Actual results:
සමච්ච්ලය

Expected results:
සමච්ච්ලය.

Comment 1 Daiki Ueno 2010-07-16 00:57:10 UTC
Posted a workaround patch to the upstream:

http://code.google.com/p/ibus/issues/detail?id=1005

Comment 2 Fedora Update System 2010-07-16 07:07:52 UTC
ibus-m17n-1.3.0-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ibus-m17n-1.3.0-2.fc13

Comment 3 Fedora Update System 2010-07-16 07:09:12 UTC
ibus-m17n-1.3.0-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ibus-m17n-1.3.0-2.fc12

Comment 4 Harshula Jayasuriya 2010-07-16 07:13:24 UTC
The latest F13 package fixes the bug for me.

Comment 5 Fedora Update System 2010-07-16 18:52:44 UTC
ibus-m17n-1.3.0-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-m17n'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ibus-m17n-1.3.0-2.fc12

Comment 6 Fedora Update System 2010-07-16 18:53:26 UTC
ibus-m17n-1.3.0-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-m17n'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ibus-m17n-1.3.0-2.fc13

Comment 7 Harshula Jayasuriya 2010-07-24 08:33:35 UTC
Further testing with the new ibus-m17n-1.3.0-2 F13 package found a regression. Reverting back to ibus-m17n-1.3.0-1 resolves the problem.

Steps to Reproduce:
1. open gedit
2. select the Wijesekera keyboard layout in IBus
3. repeatedly type (multiple times): fkda

Actual results:
නෝෙනා්නෝනෝනෝනෝෙනා්ෙනා්

Expected results:
නෝනෝනෝනෝනෝනෝනෝනෝ

It looks like the pre-edit buffer is getting committed too soon in some instances.

Comment 8 Daiki Ueno 2010-07-26 01:16:31 UTC
Hmm, strange.  I can type the above example correctly with ibus-m17n-1.3.0-2.
Could you provide further debugging information with:

MDEBUG_INPUT=1 ibus-daemon -r --verbose -x >& /tmp/ibus-daemon-debug.log &

Comment 9 Harshula Jayasuriya 2010-07-26 05:48:51 UTC
I had upgraded the m17n packages.

root@serendib:~# rpm -qa 'm17n*'
m17n-contrib-1.1.11-4.fc14.noarch
m17n-db-devel-1.6.1-3.fc14.noarch
m17n-db-1.6.1-3.fc14.noarch
m17n-lib-1.6.1-2.fc14.x86_64

root@serendib:~# rpm -qa 'ibus*'
ibus-1.3.6-1.fc13.x86_64
ibus-anthy-1.2.1-1.fc13.x86_64
ibus-libs-1.3.6-1.fc13.x86_64
ibus-chewing-1.3.5.20100706-1.fc13.x86_64
ibus-rawcode-1.3.1.20100707-1.fc13.x86_64
ibus-pinyin-db-open-phrase-1.3.9-1.fc13.noarch
ibus-gtk-1.3.6-1.fc13.x86_64
ibus-pinyin-1.3.9-1.fc13.x86_64
ibus-hangul-1.3.0.20100329-1.fc13.x86_64
ibus-m17n-1.3.0-2.fc13.x86_64

The Wijesekera MIM file used:
http://cvs.m17n.org/viewcvs/m17n/m17n-db/MIM/si-wijesekera.mim?revision=1.10&view=markup

Comment 10 Harshula Jayasuriya 2010-07-26 05:50:00 UTC
Created attachment 434340 [details]
corresponding output: නෝෙනා්නෝනෝෙනා්

Comment 11 Daiki Ueno 2010-07-26 06:41:03 UTC
Still I can't reproduce it on F-13 and F-14.

From the log, unwanted "input-focus-move" events occurred on your environment.  The event type was added quite recently and perhaps is not so mature:

https://code.google.com/p/ibus/issues/detail?id=888

Anyway, I'll look into it further.

One question: did you touched mouse or touchpad while typing the letters?

Comment 12 Harshula Jayasuriya 2010-07-26 06:56:49 UTC
I double checked and I'm not touching the touchpad. I also reproduced it while raising my palms off the wrist rest area.

Comment 13 Fedora Update System 2010-07-27 07:47:17 UTC
ibus-m17n-1.3.0-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ibus-m17n-1.3.0-3.fc13

Comment 14 Fedora Update System 2010-07-27 07:48:40 UTC
ibus-m17n-1.3.0-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ibus-m17n-1.3.0-3.fc12

Comment 15 Fedora Update System 2010-07-30 08:42:47 UTC
ibus-m17n-1.3.0-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-m17n'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ibus-m17n-1.3.0-3.fc12

Comment 16 Fedora Update System 2010-07-30 08:45:23 UTC
ibus-m17n-1.3.0-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-m17n'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ibus-m17n-1.3.0-3.fc13

Comment 17 Fedora Admin XMLRPC Client 2010-08-02 06:20:57 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 18 Fedora Update System 2010-08-13 21:08:10 UTC
ibus-m17n-1.3.0-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2010-08-13 21:31:42 UTC
ibus-m17n-1.3.0-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.