Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 614889 - virt-v2v | fail to install SCSI controller driver in some guests which will cause BSOD,
virt-v2v | fail to install SCSI controller driver in some guests which will c...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.6
All Linux
high Severity high
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
: Reopened
Depends On:
Blocks: 615981
  Show dependency treegraph
 
Reported: 2010-07-15 09:49 EDT by Mohua Li
Modified: 2013-04-30 19:13 EDT (History)
9 users (show)

See Also:
Fixed In Version: virt-v2v-0.7.1-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 615981 (view as bug list)
Environment:
Last Closed: 2011-08-05 13:39:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log for 20082 offline convert (912.28 KB, text/plain)
2010-07-15 10:06 EDT, Mohua Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1125 normal SHIPPED_LIVE virt-v2v and libguestfs enhancement update 2011-08-05 13:38:28 EDT

  None (edit)
Description Mohua Li 2010-07-15 09:49:38 EDT
Description of problem:
sometimes, in offline convert, still fail to install the SCSI controller driver, especially for windows7 or windows 2008 R2,although could install other drivers successfully in the firstboot with iso files available, but still will cause BSOD after reboot,


Version-Release number of selected component (if applicable):
virt-v2v-0.6.1-1.el6.x86_64
libguestfs-1.2.7-1.el6.5.x86_64

How reproducible:
sometimes

Steps to Reproduce:
1,convert the windows7 guest successfully without any error,
2,import the guest,
3,start the vm guest, wait some time to let the driver install successfully,
4,login into the guest, check the driver with "device manager",

  
Actual results:
sometimes, the windows guest fail to install the scsi disk controller driver, 

Expected results:
could 100% sure the driver installed successfully in offline convert 

Additional info:
Comment 1 Mohua Li 2010-07-15 10:06:15 EDT
Created attachment 432092 [details]
log for 20082 offline convert
Comment 2 Yewei Shao 2010-07-21 04:49:44 EDT
Matt said this is not a blocker because there are so many ways a user can currently break Windows conversion, so he doesn't think it's worth singling out this one. So remove the "TestBlock" keyword and "blocker" flag for this bug.
Comment 4 RHEL Product and Program Management 2010-08-09 15:51:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Matthew Booth 2011-05-25 05:49:33 EDT

*** This bug has been marked as a duplicate of bug 615981 ***
Comment 7 Matthew Booth 2011-05-25 06:03:40 EDT
Bug 615981 is a RHEL 6 bug. This isn't a duplicate.
Comment 8 Rita Wu 2011-05-26 03:01:49 EDT
Verified with virt-v2v-0.7.1-4.el5.

The new v2v mechanism will try to install virtio driver via copying drivers into corresponding dir instead of CDUpgrader's help. So this issue has been resolved automatically after mechanism update.
Comment 9 errata-xmlrpc 2011-08-05 13:39:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1125.html

Note You need to log in before you can comment on or make changes to this bug.