Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 614930 - Can't control idle time
Can't control idle time
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
13
i686 Linux
low Severity high
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 11:08 EDT by dmichaud
Modified: 2010-07-15 12:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 11:55:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dmichaud 2010-07-15 11:08:11 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.4) Gecko/20100622 Fedora/3.6.4-1.fc13 Firefox/3.6.4

In previous versions of Fedora, it was possible to control the idle time reporting of the default IM client. Specifically if and how long one can be "idle" before IM statuses change. It was also possible to disable idle time reporting completely. 

In Fedora 13, the default IM client "Empathy" does not allow ANY control of idle time behavior.

Maintaining user control of "idle" status is critical for business users, as well as privacy conscious individuals.

Reproducible: Always

Steps to Reproduce:
Get online with Empathy,

Observer there is no interface to control idle time reporting or when status changes happen due to "idle" time.



Because of this bug I had to go back and install pidgin.
Comment 1 Brian Pepple 2010-07-15 11:55:56 EDT
The idle time is controlled by the gnome-screensaver idle setting. There is no reason to duplicate this setting within Empathy. If the user wants to manually change their status they can (either to AWAY or BUSY). Closing as WONTFIX since this is the behaviour upstream wants (and frankly *is* the correct way to do it).
Comment 2 dmichaud 2010-07-15 12:11:50 EDT
I think you are misunderstanding the use case. 

My screensaver is on a short timer for security reasons. I *DON'T* want my instant message client to blurt that I'm away or busy each time it kicks off. This could have negative professional repercussions. I don't think I'm the only one in this situation or even in a minority 10% use case.

Suggest re-evaluating the lack of idle time control.. a feature that was removed from previous versions.. and perhaps toning down the inexplicable arrogance regarding correctness of how IM is to be used.

Note You need to log in before you can comment on or make changes to this bug.