Bug 614965 - SELinux is preventing /usr/sbin/semodule "connectto" access on /var/lib/sss/pipes/nss.
SELinux is preventing /usr/sbin/semodule "connectto" access on /var/lib/...
Status: CLOSED DUPLICATE of bug 598191
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:502ecc20faf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 12:21 EDT by Andy Sturrock
Modified: 2010-07-15 13:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 13:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Sturrock 2010-07-15 12:21:51 EDT
Summary:

SELinux is preventing /usr/sbin/semodule "connectto" access on
/var/lib/sss/pipes/nss.

Detailed Description:

[semodule has a permissive type (semanage_t). This access was not denied.]

SELinux denied access requested by semodule. It is not expected that this access
is required by semodule and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:semanage_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                /var/lib/sss/pipes/nss [ unix_stream_socket ]
Source                        semodule
Source Path                   /usr/sbin/semodule
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           policycoreutils-2.0.82-13.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-10.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.3-85.fc13.x86_64 #1 SMP
                              Thu May 6 18:09:49 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Thu 15 Jul 2010 17:06:49 BST
Last Seen                     Thu 15 Jul 2010 17:06:49 BST
Local ID                      a7f3ebd3-9d45-422d-b575-7890b1b38c54
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1279210009.189:33769): avc:  denied  { connectto } for  pid=4472 comm="semodule" path="/var/lib/sss/pipes/nss" scontext=unconfined_u:unconfined_r:semanage_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket

node=(removed) type=SYSCALL msg=audit(1279210009.189:33769): arch=c000003e syscall=42 success=yes exit=4294967424 a0=6 a1=7fff4ebe70f0 a2=6e a3=7fff4ebe6dc0 items=0 ppid=4442 pid=4472 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts3 ses=1 comm="semodule" exe="/usr/sbin/semodule" subj=unconfined_u:unconfined_r:semanage_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,semodule,semanage_t,unconfined_t,unix_stream_socket,connectto
audit2allow suggests:

#============= semanage_t ==============
allow semanage_t unconfined_t:unix_stream_socket connectto;
Comment 1 Daniel Walsh 2010-07-15 13:41:01 EDT

*** This bug has been marked as a duplicate of bug 598191 ***

Note You need to log in before you can comment on or make changes to this bug.