Bug 614989 - luksAddKey / device mapper complains
Summary: luksAddKey / device mapper complains
Status: CLOSED DUPLICATE of bug 613909
Alias: None
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: LVM and device-mapper development team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-15 17:46 UTC by Nathanael Noblet
Modified: 2010-07-16 09:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 09:48:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathanael Noblet 2010-07-15 17:46:25 UTC
Description of problem:
when running some of the cryptsetup options it complains with

device-mapper: remove ioctl failed: Device or resource busy

and in dmesg you get

device-mapper: ioctl: unable to remove open device temporary-cryptsetup-9696

It *does* however work, but is very confusing as you would think it hadn't completed successfully.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cryptsetup luksAddKey --key-slot 4 -q -y /dev/sde3 ~gnat/keyfile
2.
3.
  
Actual results:
[root@iridium tmp]# cryptsetup luksAddKey --key-slot 2 -q -y /dev/sde3 ~gnat/keyfile
Enter any passphrase: 
Verify passphrase: 
device-mapper: remove ioctl failed: Device or resource busy
Key slot 0 unlocked.
device-mapper: remove ioctl failed: Device or resource busy


Expected results:
[root@iridium tmp]# cryptsetup luksAddKey --key-slot 2 -q -y /dev/sde3 ~gnat/keyfile
Enter any passphrase: 
Verify passphrase: 
Key slot 0 unlocked.


Additional info:

Comment 1 Milan Broz 2010-07-16 09:48:59 UTC
yes, because hald is broken...

(btw it will recover, so it is not crutical but should be fixed - I provided patch for that hal bug already...)

*** This bug has been marked as a duplicate of bug 613909 ***


Note You need to log in before you can comment on or make changes to this bug.