Bug 61502 - freetype sbit needed
freetype sbit needed
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-20 14:40 EST by Won-kyu Park
Modified: 2007-03-26 23:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-03 02:06:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is a mandrake patch (21.09 KB, patch)
2002-03-22 01:42 EST, Won-kyu Park
no flags Details | Diff

  None (edit)
Description Won-kyu Park 2002-03-20 14:40:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461)

Description of problem:
freetype1 has already sbit functionality. but XF86 did not use this
ability

recently I found that, there exists some freetype-sbit patch, and  Mandrake 
adopted It.

related URL: first author! (for XFree86 4.0.1)
http://www.ne.jp/asahi/linux/timecop/

Mandrake patch (adopted against 4.1.0)
==============
-------------------------------------------------------------------
Sat Aug 18 17:47:29 CEST 2001 - mfabian@suse.de

- add sbit patch to make the freetype module use embedded bitmaps
  present in some unicode/cjk TrueType fonts for small point sizes
  instead of rendering the outlines.
  (original patch xfree-ttf-patch.tar.gz is from
  <timecop@japan.co.jp> http://www.ne.jp/asahi/linux/timecop/,
  I only adapted it to work with  XFree86-4.1.0)
----------------- 

xtt module already have this functionality.

but, the xfs use freetype !!! (xfs is default for RH7.2)
then under this condition, user can't see any embedded bitmap font
with his ttf.

(people workaround this problem by using xtt module)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. a ttf with embedded bitmap fonts in it
2. xfs can't render it's sbits

	

Additional info:
Comment 1 Won-kyu Park 2002-03-22 01:42:11 EST
Created attachment 49585 [details]
this is a mandrake patch
Comment 2 Mike A. Harris 2002-05-30 18:27:28 EDT
Yu, can you have a look at this, and let me know what you think?  If you like,
I can do a test build perhaps with this patch, or at least try to apply it
for testing.  Before commiting to using it though, I would want to discuss
the matter with various people in the XFree86 and font related communities to
find out why it isn't applied already.

http://www.ne.jp/asahi/linux/timecop/software/xfree-ttf-patch.tar.gz
Comment 3 Yu Shao 2002-05-30 20:38:25 EDT
FreeType2 can handle embedded bitmap, but our freetype-2.0.4-2 can't(bugs).
Xft2 and freetype-2.1.0 combination has no problem with embedded bitmap, but
currently, freetype-2.1.0 has bugs with .ttf files, .ttc is ok.

New X core freetype module is under redevelopment from Juliusz under FreeType2.

So, both Xft2 and core freetype module have no problem with embedded bitmap, but
I am expecting a lot debug works.



Comment 4 Yu Shao 2002-08-26 22:45:11 EDT
Mike Harris will include new Freetype2 backend soon.
Comment 5 Mike A. Harris 2002-11-03 02:08:49 EST
I'm closing this as WONTFIX for now, since it is not something that we
are likely to implement or patch into our release ourselves.  This type
of functionality truely needs to be done at the XFree86.org level so that
distribution vendors do not need to endlessly patch and maintain such
patches indefinitely.

My understanding from the above, and from XFree86 mailing lists, is that
this will be supported one way or another in a future XFree86 release,
either 4.3.0 or later.  So even though I'm closing this WONTFIX right now,
it is possible that it is already present in my CVS builds, or might
be present in 4.3.0 when it is released.

Either way, it is something upstream needs to do.

Note You need to log in before you can comment on or make changes to this bug.