Bug 615026 - [Multi-Org] Grants for channel permission edits throws ISE
[Multi-Org] Grants for channel permission edits throws ISE
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
540
All Linux
high Severity high
: ---
: ---
Assigned To: Lukas Zapletal
Petr Sklenar
: Regression
Depends On:
Blocks: 599612 sat54-errata
  Show dependency treegraph
 
Reported: 2010-07-15 15:41 EDT by Shannon Hughes
Modified: 2010-12-16 11:32 EST (History)
6 users (show)

See Also:
Fixed In Version: spacewalk-java-1.2.39-31
Doc Type: Bug Fix
Doc Text:
An attempt to grant channel permissions failed with an internal server error. This error has been fixed, and granting channel permissions now works as expected.
Story Points: ---
Clone Of: 599612
Environment:
Last Closed: 2010-12-16 10:44:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shannon Hughes 2010-07-15 15:41:44 EDT
+++ This bug was initially created as a clone of Bug #599612 +++

Description of problem:

checksum type was getting set to null during a multiorg grant process since the checksum attribute was incorrectly named. 

run through the testplan for 599612 and confirm a grant submission will work without ISE.

this blocks 599612
Comment 1 Shannon Hughes 2010-07-15 15:51:45 EDT
pushed to master, 

a4be5dc..0801ba1  master -> master
Comment 3 Garik Khachikyan 2010-09-23 06:36:45 EDT
# VERIFIED

Checked the scenario in: https://bugzilla.redhat.com/show_bug.cgi?id=599612#c0

All is working okey now. no ISE. registered system gets subscribed to selected child channel(s) through SSM.

The current iso where the fix was checked is:
---
Satellite-5.4.0-RHEL5-re20100920.0
Comment 7 Lukas Zapletal 2010-12-01 08:44:40 EST
commit 0a57721c3b6e84b236cf3fccf10822edc90304b6
Author: Lukas Zapletal <lzap+git@redhat.com>
Date:   Wed Nov 24 11:55:36 2010 +0100

    615026 - [Multi-Org] Grants for channel permission edits throws ISE
    
    Fixing NPE in edit channel action.
    
    (cherry picked from commit b19d7f3dc65f0e9760c58146923f9af36c134548)
Comment 10 Petr Sklenar 2010-12-13 11:48:22 EST
test procedure:
1) Create 2 Orgs and give System Entitlements and Channel Entitlements to both
for RH channels including few child channels
2) Set up the Trust between these two Orgs
3) Login with psklenarA and clone base channel ( rhel-x86_64-server-6 ) and
shared it with trusted org (psklenarB)
  a) Channels -> Manage Software Channels -> Click the Clone channel -> Select
Protected -> Update Channel
--
channel was shared between organizations
tested with sat540+spacewalk-java-1.2.39-34.el5sat
--
moving to verified
Comment 12 errata-xmlrpc 2010-12-16 10:44:27 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0991.html
Comment 13 Jaromir Hradilek 2010-12-16 11:32:35 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
An attempt to grant channel permissions failed with an internal server error. This error has been fixed, and granting channel permissions now works as expected.

Note You need to log in before you can comment on or make changes to this bug.