Bug 61505 - exec of /etc/X11/xinit/Xclients in xinitrc fails
exec of /etc/X11/xinit/Xclients in xinitrc fails
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: xinitrc (Show other bugs)
7.2
noarch Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
: EasyFix, Triaged
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2002-03-20 15:10 EST by Mike Snitzer
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 02:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to source Xclients instead of exec (515 bytes, patch)
2002-03-21 15:23 EST, Mike Snitzer
no flags Details | Diff

  None (edit)
Description Mike Snitzer 2002-03-20 15:10:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.7smp i686; Nav)

Description of problem:
If I attempt to "startx" on a 7.2 install the X server starts but only displays
a grey background (only X is running no gome-session et al).  If I change
/etc/X11/xinit/xinitrc to source ('.') /etc/X11/xinit/Xclients rather than exec
Xclients everything works.  That is gnome-session starts, sawfish is loaded,
etc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  startx
2.  watch grey screen
3.  ctrl-alt-backspace
	

Actual Results:  grey screen of core X server is displayed, meaning Xclients is
never exec'd this has been verified with various echo debugging when starting X

Expected Results:  /etc/X11/xinit/Xclients should be run and then gnome-session
should be started along with sawfish and the rest of the gnome desktop.

Additional info:

I'm at a loss as to why sourcing /etc/X11/xinit/Xclients fixes the problem
whereas exec of Xclients never actually happens...  no X related rpms or files
are being modified.  If I run Xconfigurator and test the setup I specified
(while maintaining exec /etc/X11/xinit/Xclients in xinitrc) the test display
starts and works perfectly fine with sawfish, gnome panel, etc running.

After I finish Xconfigurator and type startx the grey X server just sits there;
that is until I ctrl-alt-backspace out of X and change line 72 of
/etc/X11/xinit/xinitrc to:

    . /etc/X11/xinit/Xclients

Any suggestions?
Comment 1 Mike Snitzer 2002-03-21 15:23:35 EST
Created attachment 49486 [details]
patch to source Xclients instead of exec
Comment 2 Mike A. Harris 2002-03-21 23:11:59 EST
Are you using bash as your login shell, or tcsh or some other shell?
Comment 3 Mike Snitzer 2002-03-22 00:28:44 EST
I am using bash as the login shell. btw, Xclients has permissions 755 and has
#!/bin/bash
Comment 4 Mike A. Harris 2004-09-24 02:47:58 EDT
This bug was reported a long time ago, however I remember investigating
it when I added my initial comment above.  At that time, I was
not able to reproduce the problem.  I use startx almost exclusively
to start up the X server on all my systems, and I have never
encountered this problem on any OS release.  The code in xinitrc
simply exec's the /etc/X11/xinit/Xclients script, which as you've
indicated above is executable.

I'm going to assume that this was a configuration or installation
quirk on your system, as no other user has reported this to us
as a bug, and many people use 'startx' to start the X server, so
the problem must have been isolated to that specific system.

Setting bug state to "WORKSFORME", as this is unreproduceable, and
nobody else seems to have this problem on other systems.

Note You need to log in before you can comment on or make changes to this bug.