Bug 615117 - removable USB devices with NTFS filesystem are not automatically mounted when inserted
removable USB devices with NTFS filesystem are not automatically mounted when...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 20:45 EDT by Arthur Kantor
Modified: 2011-06-29 09:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 483152
Environment:
Last Closed: 2011-06-29 09:27:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur Kantor 2010-07-15 20:45:18 EDT
+++ This bug was initially created as a clone of Bug #483152 +++

Created an attachment (id=330403)
udevmonitor output

Under Fedora 9, whenever I inserted a USB key, it would show up under Places->Computer menu.  Although it was not mounted automatically upon just the insertion, if I opened the Places->Computer window, it would be automatically mounted.

Under Fedora 10, no removable devices are ever automatically mounted, even if I open the Places->Computer window.

Moreover, if I open the Places->Computer window, select the device I want to mount, right-click on it, and select "Mount Volume", the device *still* is not mounted.

This isn't a big deal to me, as I normally have a root shell open, and can automatically [un]mount things as needed. But this worked properly under F9.

As far as I can tell from the udevmonitor output (attached), udev sees the device normally. Additionally, hal sees the device in at least some manner, because hal starts a process to poll it (/dev/sdb in the follow ps listing):

 2464 ?        Ss     0:00 hald
 2468 ?        S      0:00  \_ hald-runner
 2634 ?        S      0:00      \_ hald-addon-hid-ups: listening on /dev/hiddev1
 2650 ?        S      0:00      \_ hald-addon-storage: no polling on /dev/sr0 because it is explicitly disabled
 2655 ?        S      0:00      \_ hald-addon-storage: no polling on /dev/fd0 because it is explicitly disabled
 2657 ?        S      0:00      \_ /usr/libexec/hald-addon-cpufreq
 2659 ?        S      0:00      \_ hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
 2711 ?        S      0:00      \_ hald-addon-input: Listening on /dev/input/event0 /dev/input/event4 /dev/input/event3 /dev/input/event1
 7065 ?        S      0:00      \_ hald-addon-storage: polling /dev/sdb (every 2 sec)

The only thing that I have explicitly done that I can think might be related is that I ran hal-disable-polling on /dev/sr0 (per the advice of powertop). But I don't see why that would have affected USB devices.

--- Additional comment from ralston@pobox.com on 2009-01-29 16:01:33 EST ---

When F11 Rawhide is cut, I'll install it on my laptop and test to see whether this problem still exists.

--- Additional comment from antonio.montagnani@alice.it on 2009-01-30 14:40:58 EST ---

existing also on F11

--- Additional comment from antonio.montagnani@alice.it on 2009-01-30 14:48:24 EST ---

but it works if file system is Fat, not working if NTFS!!! Shall I file a separate bug??

--- Additional comment from kantor@cs.wisc.edu on 2010-07-15 20:32:19 EDT ---

This is still a problem in Fedora 13.  Note that FAT32 formatted partitions work fine, but NTFS partitions don't mount.  This is useful for USB hard disks.
Comment 1 John Rosich 2010-12-22 11:14:17 EST
Have the same problem with rawhide (*fc15*)
Comment 2 Bug Zapper 2011-06-01 09:46:40 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2011-06-29 09:27:36 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.