Bug 615158 - Do not change the background colour of the pre-edit buffer
Do not change the background colour of the pre-edit buffer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-m17n (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 23:37 EDT by Harshula Jayasuriya
Modified: 2010-09-15 01:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-m17n-1.3.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 01:08:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harshula Jayasuriya 2010-07-15 23:37:42 EDT
Description of problem:

Got some feedback from a m17n Wijesekera keyboard layout user who is involved in publishing. He finds it difficult to work for long periods of time using IBus because the pre-edit buffer has a background colour that is different to the rest of the application's text input box.

Could we add a tick box option in the IBus preferences that toggles between setting the background colour of the pre-edit buffer and underlining the pre-edit buffer with no change to the background colour. SCIM underlines the pre-edit buffer, which appears to improve usability.

At the moment, the particular user has had to switch back to SCIM because using IBus was affecting his productivity.

Version-Release number of selected component (if applicable):
ibus-chewing-1.3.4.20100608-1.fc13.i686
ibus-pinyin-db-android-1.3.8-1.fc13.noarch
ibus-anthy-1.2.1-1.fc13.i686
ibus-libs-1.3.6-1.fc13.i686
ibus-pinyin-1.3.8-1.fc13.i686
ibus-m17n-1.3.0-1.fc13.i686
ibus-1.3.6-1.fc13.i686
ibus-hangul-1.3.0.20100329-1.fc13.i686
ibus-gtk-1.3.6-1.fc13.i686
ibus-rawcode-1.3.1.20100707-1.fc13.i686

How reproducible:
Always

Steps to Reproduce:
1. open gedit
2. select the Wijesekera keyboard layout in IBus
3. type the key sequence: fkda

Actual results:
* The text in the pre-edit buffer appears with a black background colour.

Expected results:
* The text in the pre-edit buffer appearing with the same background colour as the rest of the text input box. Alternately, underline the text in the pre-edit buffer instead of changing the background colour.
Comment 1 Daiki Ueno 2010-07-21 01:37:31 EDT
I posted a patch to make the appearance of the pre-edit buffer configurable:
http://code.google.com/p/ibus/issues/detail?id=1008
Comment 2 Daiki Ueno 2010-07-30 00:53:57 EDT
I put the RPM and SRPM for ibus-m17n with configuration UI:

http://ueno.fedorapeople.org/ibus-m17n/

Since the last time Harshula tested, the following changes are included:

- Pre-edit colors are no longer set for some input methods (including si-wijesekera and th-kesmanee), which do not need word conversion, by default.
- Pre-edit colors can be "unset".

Further testing would be much appreciated.
Comment 3 Harshula Jayasuriya 2010-07-30 01:27:48 EDT
I did a quick test in gedit & oowriter. Looks great, usability has improved significantly.
Comment 4 Fedora Admin XMLRPC Client 2010-08-02 02:20:55 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Update System 2010-09-03 04:57:30 EDT
ibus-m17n-1.3.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-m17n-1.3.1-1.fc14
Comment 6 Fedora Update System 2010-09-03 04:57:36 EDT
ibus-m17n-1.3.1-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/ibus-m17n-1.3.1-1.fc13
Comment 7 Fedora Update System 2010-09-03 12:44:58 EDT
ibus-m17n-1.3.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-m17n'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/ibus-m17n-1.3.1-1.fc14
Comment 8 Fedora Update System 2010-09-14 01:08:43 EDT
ibus-m17n-1.3.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-09-15 01:26:35 EDT
ibus-m17n-1.3.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.