This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 615187 - Call trace in rhel6 PV guest after doing "xm save" failure.
Call trace in rhel6 PV guest after doing "xm save" failure.
Status: CLOSED DUPLICATE of bug 618569
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Red Hat Kernel QE team
: TestOnly
Depends On: 497080
Blocks: 523117
  Show dependency treegraph
 
Reported: 2010-07-16 01:48 EDT by XinSun
Modified: 2011-04-20 08:36 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-20 08:36:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rhel6-call_trace.txt (2.62 KB, text/plain)
2010-07-16 01:48 EDT, XinSun
no flags Details
xend.log (5.66 KB, text/plain)
2010-07-16 01:49 EDT, XinSun
no flags Details
rhel6-pv-latest (537 bytes, text/plain)
2010-07-16 01:51 EDT, XinSun
no flags Details

  None (edit)
Description XinSun 2010-07-16 01:48:53 EDT
Created attachment 432302 [details]
rhel6-call_trace.txt

Description of problem:
After doing rhel6 pv guest save failure, rhel6 pv guest will call trace and hang.


Version-Release number of selected component (if applicable):
xen-3.0.3-114.el5
kernel-xen-2.6.18-206.el5

How reproducible:
Always

Steps to Reproduce:
1.Create the rhel6 pv guest:  xm create rhel6-pv-latest -c
2.save this guest to small disk:  xm save rhel6-pv-latest /mnt/save_fail
  
Actual results:
There is call trace in rhel6 PV guest and guest will hang.

Expected results:
Rhel6 PV guest will run normal and you can operate this guest all the time.


Additional info:
Please see the attachment: rhel6_call_trace.txt
                           xend.log
                           rhel6-pv-latest.txt (guest config file)
Comment 1 XinSun 2010-07-16 01:49:45 EDT
Created attachment 432303 [details]
xend.log
Comment 4 Andrew Jones 2010-07-16 08:10:57 EDT
question to reporter or xen user space guys: do RHEL5 guests recover from failed saves fine?
Comment 5 XinSun 2010-07-19 03:46:26 EDT
I try this on rhel5 pv guest, when doing save failure on rhel5.5 pv guest, this guest can run normally and I can do other operation in this guest.
Comment 6 XinSun 2010-07-19 06:16:57 EDT
Retest it again, this issue occurs on i386 platfrom.
Comment 7 Michal Novotny 2010-07-19 09:16:39 EDT
Andrew: Yeah, now it does. From the xend.log I was seeing "errno 28" which is failure because of low disk space which is change because for me I saw "errno 0" for RHEL-5 i386 guest. Nevertheless, the RHEL-5 i386 guest I tested was working successfully when resumed from the failed save (at least according to my testing). This was tested on x86_64 RHEL-5 host.

Also, the "arch/x86/xen/enlighten.c:169" in the call trace is present only in the recent pv-ops kernels like you told me... Could what's present on line 169 in this file of RHEL-6 kernel then?

Thanks,
Michal
Comment 8 Andrew Jones 2010-07-20 02:53:10 EDT
It looks like we may need to fix this in the rhel6 kernel, possible also a change in the rhel5 HV. In any respect it's too late for 6.0 to fix this as it's an error path and not a critical blocker. Moving to kernel component and slating for 6.1.

Drew
Comment 11 RHEL Product and Program Management 2011-01-06 23:36:35 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 12 Suzanne Yeghiayan 2011-01-07 11:11:44 EST
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.
Comment 13 RHEL Product and Program Management 2011-02-01 01:08:25 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 14 RHEL Product and Program Management 2011-02-01 13:29:03 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 15 Paolo Bonzini 2011-04-20 08:34:16 EDT
This would be fixed by suspend cancellation, we are not going to fix it in the guest.
Comment 16 Paolo Bonzini 2011-04-20 08:36:19 EDT

*** This bug has been marked as a duplicate of bug 618569 ***

Note You need to log in before you can comment on or make changes to this bug.