Bug 615195 - Agent crash with 32 bit j9 JDK on 64 bit AIX
Summary: Agent crash with 32 bit j9 JDK on 64 bit AIX
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Agent   
(Show other bugs)
Version: 3.0.1
Hardware: ppc Other
medium
high vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-16 06:31 UTC by James Livingston
Modified: 2018-11-14 12:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
32 bit j9 JDK on 64 bit AIX
Last Closed: 2014-06-04 19:52:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 56369 None None None Never

Description James Livingston 2010-07-16 06:31:53 UTC
A while back a bug got reported against upstream SIGAR[0] where JON agent would crash if they were run in a 32 bit j9 JDK on 64 bit AIX, and it was eventually closed "unable to reproduce". A customer has reported this occurring.

I've tried to reproduce this on a 64 AIX machine in the Metamatrix lab, but haven't managed to do so, or by running the SIGAR tests.


It may be a good idea to have the agent warn if it detects it is running in a 32 bit JVM on 64 bit AIX, and tell the user to run in a 64 bit JVM instead.



[0] http://jira.hyperic.com/browse/SIGAR-143

Comment 2 Larry O'Leary 2011-05-20 20:53:09 UTC
Looks like this issue has come up again. If a 64-bit JVM is required, we should make sure this is documented. Updated version to reflect RHQ 3.0.1.


Note You need to log in before you can comment on or make changes to this bug.