Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 615270 - cciss disk devices have empty block.device property in HAL
cciss disk devices have empty block.device property in HAL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: udev (Show other bugs)
5.4
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Harald Hoyer
Martin Cermak
: ZStream
Depends On: 515566
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-16 06:22 EDT by RHEL Product and Program Management
Modified: 2016-04-26 11:48 EDT (History)
29 users (show)

See Also:
Fixed In Version: udev-095-14.21.el5_5.1
Doc Type: Bug Fix
Doc Text:
Previously, cciss devices did not have an entry in the udev database. This was caused by the fact that these devices do not provide information in the /sys file system, making it hard to create persistent symbolic links in /dev/disk. With this update, the scsi_id utility is used to query the ID of cciss devices, so that udev can create the database entries as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 10:29:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0593 normal SHIPPED_LIVE udev bug fix update 2010-08-04 10:29:56 EDT

  None (edit)
Description RHEL Product and Program Management 2010-07-16 06:22:43 EDT
This bug has been copied from bug #515566 and has been proposed
to be backported to 5.5 z-stream (EUS).
Comment 3 Harald Hoyer 2010-07-21 10:55:27 EDT
udev-095-14.21.el5_5.1
Comment 5 Jaromir Hradilek 2010-07-23 06:45:48 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Previously, cciss devices did not have an entry in the udev database. This was caused by the fact that these devices do not provide information in the /sys file system, making it hard to create persistent symbolic links in /dev/disk. With this update, the scsi_id utility is used to query the ID of cciss devices, so that udev can create the database entries as expected.
Comment 9 errata-xmlrpc 2010-08-04 10:29:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0593.html

Note You need to log in before you can comment on or make changes to this bug.