Bug 615323 - gq - sort results not working
Summary: gq - sort results not working
Status: CLOSED DUPLICATE of bug 520342
Alias: None
Product: Fedora
Classification: Fedora
Component: gq   
(Show other bugs)
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-16 14:05 UTC by Daniele Branchini
Modified: 2010-08-30 19:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-30 19:12:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniele Branchini 2010-07-16 14:05:37 UTC
Description of problem:

in the browse tab results are displayed unsorted, even when "sort results" is checked in the preferences window


Version-Release number of selected component (if applicable):

gq-1.3.4-8.fc12 i686
gq-1.3.4-8.fc12 x86_64

How reproducible:

link a ldap server, browse it


Steps to Reproduce:
1. in the prefernce windows edit server list and set "sort results"
2. go to the browse tab
3. browse the server
  
Actual results:

results unsorted


Expected results:

results alphabetically sorted

Additional info:
In a comparison with ldapsearch, let's say I want to browse the "ou" People, the result order is the same of:
ldapsearch -h ldap -b "ou=People,dc=something" -x

I was expecting the same behaviour of version 1.2.2-7.fc8, similar to:
ldapsearch -h ldap -b "ou=People,dc=something" -S "uid" -x

Comment 1 Terje Røsten 2010-08-30 19:12:35 UTC
There are a number of problematic issues with gq_ a lot of crashes and a dead
upstream. Seems like the best way forward is to find a good replacement.

*** This bug has been marked as a duplicate of bug 520342 ***


Note You need to log in before you can comment on or make changes to this bug.