Bug 615386 - automount[3035]: open_lookup:90: cannot open lookup module ldap (/usr/lib64/autofs/lookup_ldap.so: undefined symbol: krb5_get_init_creds_keytab)
automount[3035]: open_lookup:90: cannot open lookup module ldap (/usr/lib64/a...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
14
All Linux
high Severity high
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-07-16 12:29 EDT by Orion Poplawski
Modified: 2011-06-02 11:08 EDT (History)
3 users (show)

See Also:
Fixed In Version: autofs-5.0.5-29.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 23:25:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2010-07-16 12:29:38 EDT
Description of problem:

Current rawhide, autofs is unable to load ldap module:

automount[3035]: open_lookup:90: cannot open lookup module ldap (/usr/lib64/autofs/lookup_ldap.so: undefined symbol: krb5_get_init_creds_keytab)

Version-Release number of selected component (if applicable):
autofs-5.0.5-27.fc14.x86_64

This system was yum upgraded from F13.

# ldd /usr/lib64/autofs/lookup_ldap.so 
        linux-vdso.so.1 =>  (0x00007fffb7776000)
        libldap-2.4.so.2 => /usr/lib64/libldap-2.4.so.2 (0x00007fa0db154000)
        liblber-2.4.so.2 => /usr/lib64/liblber-2.4.so.2 (0x00007fa0daf46000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fa0dad2a000)
        libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00007fa0dab10000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007fa0da7be000)
        libz.so.1 => /lib64/libz.so.1 (0x00007fa0da5a6000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fa0da322000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fa0d9f8d000)
        libssl3.so => /usr/lib64/libssl3.so (0x00007fa0d9d58000)
        libsmime3.so => /usr/lib64/libsmime3.so (0x00007fa0d9b2d000)
        libnss3.so => /usr/lib64/libnss3.so (0x00007fa0d97f3000)
        libnssutil3.so => /usr/lib64/libnssutil3.so (0x00007fa0d95d3000)
        libplds4.so => /lib64/libplds4.so (0x00007fa0d93d0000)
        libplc4.so => /lib64/libplc4.so (0x00007fa0d91cc000)
        libnspr4.so => /lib64/libnspr4.so (0x00007fa0d8f8e000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fa0d8d8a000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fa0d8b53000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fa0db5cd000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fa0d8934000)
        libfreebl3.so => /lib64/libfreebl3.so (0x00007fa0d86d7000)

Looks like it is no longer linked against the krb libraries.
Comment 1 Ian Kent 2010-07-17 00:08:41 EDT
(In reply to comment #0)
> Description of problem:
> 
> Current rawhide, autofs is unable to load ldap module:
> 
> automount[3035]: open_lookup:90: cannot open lookup module ldap
> (/usr/lib64/autofs/lookup_ldap.so: undefined symbol:
> krb5_get_init_creds_keytab)
> 
> Version-Release number of selected component (if applicable):
> autofs-5.0.5-27.fc14.x86_64
> 
> This system was yum upgraded from F13.
> 
> # ldd /usr/lib64/autofs/lookup_ldap.so 
>         linux-vdso.so.1 =>  (0x00007fffb7776000)
>         libldap-2.4.so.2 => /usr/lib64/libldap-2.4.so.2 (0x00007fa0db154000)
>         liblber-2.4.so.2 => /usr/lib64/liblber-2.4.so.2 (0x00007fa0daf46000)
>         libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fa0dad2a000)
>         libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00007fa0dab10000)
>         libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007fa0da7be000)
>         libz.so.1 => /lib64/libz.so.1 (0x00007fa0da5a6000)
>         libm.so.6 => /lib64/libm.so.6 (0x00007fa0da322000)
>         libc.so.6 => /lib64/libc.so.6 (0x00007fa0d9f8d000)
>         libssl3.so => /usr/lib64/libssl3.so (0x00007fa0d9d58000)
>         libsmime3.so => /usr/lib64/libsmime3.so (0x00007fa0d9b2d000)
>         libnss3.so => /usr/lib64/libnss3.so (0x00007fa0d97f3000)
>         libnssutil3.so => /usr/lib64/libnssutil3.so (0x00007fa0d95d3000)
>         libplds4.so => /lib64/libplds4.so (0x00007fa0d93d0000)
>         libplc4.so => /lib64/libplc4.so (0x00007fa0d91cc000)
>         libnspr4.so => /lib64/libnspr4.so (0x00007fa0d8f8e000)
>         libdl.so.2 => /lib64/libdl.so.2 (0x00007fa0d8d8a000)
>         libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fa0d8b53000)
>         /lib64/ld-linux-x86-64.so.2 (0x00007fa0db5cd000)
>         libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fa0d8934000)
>         libfreebl3.so => /lib64/libfreebl3.so (0x00007fa0d86d7000)
> 
> Looks like it is no longer linked against the krb libraries.    

If you grab the source rpm and build it does that make the
problem go away? It may just need a rebuild to account for
library changes. But maybe there have been library changes
that need a bit more work, that would be good to know.
Comment 2 Orion Poplawski 2010-07-19 13:55:04 EDT
Rebuild doesn't help.

modules/cyrus-sasl.c calls krb5 functions so the lookup_ldap module which uses it needs to link against krb5 lib.  Perhaps some other library that autofs links against used to link against krb5 but no longer does.  Not sure why you don't get warnings at link time.

Also, the init script is broken for restarts.  I think this fixes:

diff -u -r1.1 autofs-5.0.5-make-redhat-init-script-more-lsb-compliant.patch
--- autofs-5.0.5-make-redhat-init-script-more-lsb-compliant.patch       24 May 2010 03:01:04 -0000       1.1
+++ autofs-5.0.5-make-redhat-init-script-more-lsb-compliant.patch       19 Jul 2010 17:47:14 -0000
@@ -61,7 +61,7 @@
  
  function restart() {
 -      stop
-+      status > /dev/null 2>&1
++      status -p /var/run/autofs.pid -l autofs $prog > /dev/null 2>&1
 +      if [ $? -eq 0 ]; then
 +              stop
 +      fi
Comment 3 Ian Kent 2010-07-19 22:30:40 EDT
(In reply to comment #2)
> Rebuild doesn't help.
> 
> modules/cyrus-sasl.c calls krb5 functions so the lookup_ldap module which uses
> it needs to link against krb5 lib.  Perhaps some other library that autofs
> links against used to link against krb5 but no longer does.  Not sure why you
> don't get warnings at link time.

Maybe it was the SASL libs, I'll add the krb5 lib.

> 
> Also, the init script is broken for restarts.  I think this fixes:

Yeah, I saw that but hadn't had a chance to look into it.

Thanks for your effort.
Ian
Comment 4 Bug Zapper 2010-07-30 08:37:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Orion Poplawski 2010-08-09 12:25:41 EDT
This really makes Fedora 14 unusable for me.  Can we get this fixed soon so I can do more testing with it?  Thanks!
Comment 6 Ian Kent 2010-08-09 22:02:43 EDT
(In reply to comment #5)
> This really makes Fedora 14 unusable for me.  Can we get this fixed soon so I
> can do more testing with it?  Thanks!    

Sorry, will do.
Ian
Comment 7 Ian Kent 2010-08-10 05:02:12 EDT
I've done a Rawhide build which may resolve this issue.
It should be OK on Fedora 14 so could you try it out please.
If it does the trick I'll apply the chnages to F-14 proper.

The build can be found at:
http://kojipkgs.fedoraproject.org/packages/autofs/5.0.5/28.fc15
Comment 8 Orion Poplawski 2010-08-10 11:33:56 EDT
Now getting:

open_lookup:90: cannot open lookup module ldap (/usr/lib64/autofs/lookup_ldap.so: undefined symbol: ERR_remove_state)
Comment 9 Ian Kent 2010-08-11 02:33:59 EDT
(In reply to comment #8)
> Now getting:
> 
> open_lookup:90: cannot open lookup module ldap
> (/usr/lib64/autofs/lookup_ldap.so: undefined symbol: ERR_remove_state)    

Right, this call should never have been needed and it appears it
isn't needed now. I'll get rid of it.
Comment 10 Ian Kent 2010-08-11 08:13:28 EDT
So lets try this again with:
http://kojipkgs.fedoraproject.org/packages/autofs/5.0.5/29.fc15
Comment 11 Orion Poplawski 2010-08-11 10:28:52 EDT
That did the trick.  Thanks!
Comment 12 Ian Kent 2010-08-11 23:14:11 EDT
(In reply to comment #11)
> That did the trick.  Thanks!    

OK, I'll apply those changes to F14 as well but lets give
it a few days to ensure the removal of ERR_remove_state()
is not going to be a problem.
Comment 13 Ian Kent 2010-08-12 00:35:32 EDT
I've added this to the F14 blocker list even though we have
a solution since we do need to delay committing this for a
few days of testing. I also need to ensure that I can commit
the change and that it will be included in the release Bill?
Comment 14 Bill Nottingham 2010-08-12 12:21:28 EDT
You'd need to build it and submit a bodhi update, and follow the update's process to make sure it gets enough testing and gets pushed final. But that shouldn't be a big issue.
Comment 15 Fedora Update System 2010-08-16 22:31:36 EDT
autofs-5.0.5-29.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/autofs-5.0.5-29.fc14
Comment 16 Fedora Update System 2010-08-17 15:35:35 EDT
autofs-5.0.5-29.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update autofs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/autofs-5.0.5-29.fc14
Comment 17 Fedora Update System 2010-08-25 23:25:08 EDT
autofs-5.0.5-29.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.