Bug 615397 - CCISS drives were showing up as mpath devices during the install causing it to fail.
CCISS drives were showing up as mpath devices during the install causing it t...
Status: CLOSED DUPLICATE of bug 592998
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Red Hat Kernel QE team
:
Depends On:
Blocks: 647893
  Show dependency treegraph
 
Reported: 2010-07-16 12:54 EDT by Barry Donahue
Modified: 2010-11-29 11:14 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-29 11:14:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the trace I scp'ed to my system after the install failure. (336.03 KB, text/plain)
2010-07-16 12:55 EDT, Barry Donahue
no flags Details

  None (edit)
Description Barry Donahue 2010-07-16 12:54:53 EDT
Description of problem: I was installing RHEL6.0-Snapshot-7 on a system with a CCISS controller. The CCISS drive didn't show up under Firmware RAID where it belongs. It was under the multipath tab. If you selected the mpath device as the install target, the install failed leaving the attached trace info.

This is probably not an anaconda problem but it seems like the place to start.

Version-Release number of selected component (if applicable):
kernel 2.6.32-44.el6.x86_64
anaconda 13.21.56

How reproducible: It was happening every time until I deleted the drives from the logical drive on the CCISS controller. On the next install, the drive showed up in the Firmware RAID tab.
Comment 1 Barry Donahue 2010-07-16 12:55:55 EDT
Created attachment 432439 [details]
This is the trace I scp'ed to my system after the install failure.
Comment 2 Chris Lumens 2010-07-16 12:57:24 EDT
Please attach the output of udevadm info --export-db to this bug report.
Comment 4 Barry Donahue 2010-07-16 13:04:45 EDT
(In reply to comment #2)
> Please attach the output of udevadm info --export-db to this bug report.    

   The trace I attached is all the information I have.
Comment 5 Chris Lumens 2010-07-16 13:13:06 EDT
09:38:11,492 INFO    : Running... ['multipath', '-d']
09:38:11,788 INFO    : create: mpatha (3600508b1001037383941424344450400) undef HP,LOGICAL VOLUME
09:38:11,788 INFO    : size=137G features='0' hwhandler='0' wp=undef
09:38:11,788 INFO    : `-+- policy='round-robin 0' prio=0 status=undef
09:38:11,789 INFO    :   |- 0:0:0:0  cciss!c0d0 104:0  undef faulty running
09:38:11,789 INFO    :   |- 0:0:1:0  cciss!c0d1 104:16 undef faulty running
09:38:11,789 INFO    :   `- 0:0:2:0  cciss!c0d2 104:32 undef faulty running
Comment 6 RHEL Product and Program Management 2010-07-16 13:17:43 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 7 David Cantrell 2010-11-19 19:58:13 EST
Reassigning this one to device-mapper-multipath for their input.
Comment 8 Ben Marzinski 2010-11-22 10:20:54 EST
This looks like it's a dup of 592998. This was fixed in device-mapper-multipath-0.4.9-26.el6 (Snapshot 12). Could you please try upgrading and retesting.
Comment 9 Mike Snitzer 2010-11-29 11:14:18 EST
Barry tested on the system were he first saw this issue (as reported in comment#0) and is no longer seeing this problem (tested multiple times with RC-4).

Closing as a dup of bug# 592998

*** This bug has been marked as a duplicate of bug 592998 ***

Note You need to log in before you can comment on or make changes to this bug.