Bug 61540 - xinput patch for ami_applet
xinput patch for ami_applet
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xinitrc (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-21 03:26 EST by Won-kyu Park
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-16 08:38:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch file (493 bytes, patch)
2002-03-22 01:34 EST, Won-kyu Park
no flags Details | Diff

  None (edit)
Description Won-kyu Park 2002-03-21 03:26:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
under Korean environment.

When I first running X, ami_applet automatically attached in panel successfully.
But the next time to start with X, xinput tries to attach another ami_applet
again !! and warning window opened.

this is a small fix for it

--- xinput.orig Thu Mar 21 16:44:46 2002
+++ xinput      Thu Mar 21 17:19:16 2002
@@ -126,7 +126,11 @@
           gnome)
                if which ami_applet >/dev/null 2>&1 ; then
                         DELAY_START=2
-                       XIM_PROGRAM=ami_applet
+                       if ! grep -q "ami_applet"
~/.gnome/panel.d/default/Applet_Config 2>/dev/null ; then
+                               XIM_PROGRAM=ami_applet
+                       else
+                               XIM_PROGRAM=/bin/true
+                       fi
                        XIM_ARGS=""
                elif which ami >/dev/null 2>&1 ; then
                        XIM_PROGRAM=ami



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. under Korean Language environment (LANG=ko_KR)
2. running startx and exit
3. run startx again then you meet a warning window allways
	

Additional info:
Comment 1 Mike A. Harris 2002-03-21 21:40:52 EST
Pleas attach patches as file attachments, as they do not apply properly
via cut and paste.
Comment 2 Won-kyu Park 2002-03-22 01:34:09 EST
Created attachment 49584 [details]
patch file
Comment 3 Jens Petersen 2004-03-16 08:38:58 EST
ami-gnome has not been in the distro since RHL 8.0, so
this can be closed.

Note You need to log in before you can comment on or make changes to this bug.