Bug 615491 - Deploying a war file fails on upload (FF 3.3.6 on windowS)
Deploying a war file fails on upload (FF 3.3.6 on windowS)
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
3.0.0
All Windows
high Severity high (vote)
: ---
: ---
Assigned To: Lukas Krejci
Corey Welton
:
Depends On:
Blocks: jon-sprint12-bugs
  Show dependency treegraph
 
Reported: 2010-07-16 16:04 EDT by Andrew C. Oliver
Modified: 2010-09-28 08:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-28 08:31:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew C. Oliver 2010-07-16 16:04:14 EDT
Description of problem:
select an AS server, click inventory, create new war file, upload... after it completes it tells you that it will cause a refresh.  If you say no, it ignores the upload.  If you say yes you get a seam debug page saying it can't restore the view.  Can't copy stack trace right now.  Will try and reproduce on a box I can cut/paste from.  


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Charles Crouch 2010-07-16 16:21:58 EDT
If this is reproducible its a blocker
Comment 2 Heiko W. Rupp 2010-07-19 05:45:09 EDT
This works for me with FF2 and FF 3.6.6 on WinXP. No debug page, war is correctly deployed.
Comment 3 Andrew C. Oliver 2010-07-19 09:08:51 EDT
with a windows server?  Getting stack trace.
Comment 4 Heiko W. Rupp 2010-07-19 09:18:50 EDT
So Andy, please specify the Win* version you are using, as you did not do so before.
Comment 5 Lukas Krejci 2010-07-19 09:57:27 EDT
Andrew, the following info would be useful (apart from the stacktrace):

-- RHQ server OS version, JVM version
-- Agent OS version, JVM version
-- JBossAS version, JVM version
-- Browser OS version
-- Browser version (3.3.6 is not a version of FF)

(I'm being a bit paranoid with the JVM versions there, but you never know ;) )
Comment 6 Lukas Krejci 2010-07-19 10:32:14 EDT
Just a sidenote - I tried to replicate this on FF 3.0.6, 3.5.6 and 3.6.6 on Win2k but couldn't.
Comment 7 Lukas Krejci 2010-07-20 06:15:14 EDT
Andrew, thanks for the logs.

I see only 1 error in the logs that would correspond to this bug (namely the 2 entries starting on line 5662 in your logs) and that error is javax.faces.application.ViewExpiredException.

Off top of my head, this could be caused by 2 things:

1) the session expired, i.e. the upload took more than 30 minutes
2) you had more than 2 tabs open on the JON server in the same session (e.g. you opened a link inside JON GUI in a new tab)

The latter symptom is caused by the fact that due to the size of JSF views that need to be stored in the session, we limit the number of such stored views to 2. This means that you cannot refresh a page generated from an HTTP POST after you loaded another 2 pages in that same session.

This generally happens if you try to go back in browser history but can also happen on the package upload page if you viewed another JON page between the time you opened the upload dialog and confirmed the page refresh.

Can you please confirm either of the causes? Or do you have some other reproduction steps that can consistently reproduce this?
Comment 8 Lukas Krejci 2010-07-20 06:21:38 EDT
Uhm, replace JON with RHQ in the above comment... We're speaking RHQ, not JBoss ON here, even though everything said here applies to both.. :)
Comment 9 Charles Crouch 2010-07-20 08:43:58 EDT
Dropping the priority until we are able to reproduce this issue.
Comment 10 Charles Crouch 2010-07-20 08:46:03 EDT
Lukas, what logs?
Comment 11 Lukas Krejci 2010-07-20 08:59:30 EDT
Andrew sent them to me privately and asked not to make them public.
Comment 12 Andrew C. Oliver 2010-07-20 09:00:53 EDT
No it happens each time we upload.  A window pops up for the upload.  When the
window disappers it attempts to refresh the RHQ screen.  The browser pops up
with a warning (letting me cancel or not).  Then I get a seam exception page on
the original browser window.
Comment 14 Lukas Krejci 2010-07-20 10:11:31 EDT
Andrew, could you please look at $RHQ_HOME/jbossas/server/default/deploy/rhq.ear/rhq-portal.war/WEB-INF/web.xml and tell me the values of com.sun.faces.numberOfViewsInSession and com.sun.faces.numberOfLogicalViews context parameters?

Does this happen with an absolutely clear Firefox install (i.e. are you sure you don't have some kind of antivirus software of funky plugin that would make additional requests in the background)?
Comment 15 Andrew C. Oliver 2010-07-20 10:43:28 EDT
This is a stock default RHQ 3.0 install.  I'll ask but the values are whatever they are in the stock RHQ 3.0 install.

Asking.  I don't think so though.
Comment 16 Andrew C. Oliver 2010-07-20 12:00:17 EDT
from the customer:

"RHQ server OS/version:  MS Windows Server 2003 SP1; JVM: JBoss AS JVM  1.5.0_04
Agent OS/version:  MS Windows Server 2003 SP2; JVM:  Sun JVM, 1.6.0_20
JBoss AS server:  5.0.1; Sun JVM:  1.6.0_20
Browser OS version:  MS Windows XP Pro SP3
Browser version:  FF 3.6.6
 
com.sun.faces.numberOfViewsInSession=2
com.sun.faces.numberOfLogicalViews=2
 
A/V:  We're running Symantec Endpoint Protection
 
What developer in his right mind is going to have an absolutely clean Firefox install with no funky plugins? ;)  Here's my list of them:
 
Application: Firefox 3.6.6 (20100625231939)
Operating System: WINNT (x86-msvc)
 
- Adblock Plus 1.2.1
- All-in-One Gestures 0.21.1
- Answers 2.3.54
- Delicious Bookmarks 2.1.072
- DragNDrop Toolbars 0.0.0.9
- Extension List Dumper 1.14.8
- FEBE 6.3.3.2
- Firebug 1.5.4
- Forecastfox 0.9.10.2
- Gmail Manager 0.6
- Google Toolbar for Firefox 7.1.20100701W
- Java Console 6.0.20
- Java Console 6.0.17
- Java Quick Starter 1.0
- Microsoft .NET Framework Assistant 1.2.1"


So it probably is symantic or adblock.  I've asked them to test without (probably tomorrow).  We'll confirm and then you can close it,but maybe keep the bug around as a warning to others :-)

I bet it would work better if not for that popup window...
Comment 17 Corey Welton 2010-09-28 08:31:15 EDT
Closing per gwt efforts -- upload window will be contained within browser

Note You need to log in before you can comment on or make changes to this bug.