Bug 61552 - Segmentation fault when trying to add, upgrade, or erase packages
Segmentation fault when trying to add, upgrade, or erase packages
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Depends On:
  Show dependency treegraph
Reported: 2002-03-21 09:41 EST by Brian Johnson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-22 11:32:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian Johnson 2002-03-21 09:41:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
When I try to add, upgrade of delete rpm packages I get a segmentation fault

From trying different things, I know that it will rebuild the database, query 
packages, check for dependencies when I try to install or delete packages, and 
it through the preparing packages bar graph ... but then I get a segmentation 

If I try this:
rpm -Uvvh /backup/dnloads/Perl/*.rpm
I get:
D: ========== continuing tsort ...
D:     2    1    3  2      perl-CPAN-1.59_54-26.72.3
D: removing perl-5.6.1-26.72.3 "Requires: perl-CGI" from tsort relations.
D:     perl-5.6.1-26.72.3                       Requires: perl-CGI
D: removing perl-CGI-2.752-26.72.3 "Requires: perl >= 1:5.6.1-26.72.3" from 
tsort relations.
D:     perl-CGI-2.752-26.72.3                   Requires: perl >= 1:5.6.1-
D: ========== continuing tsort ...
D:     3    4    5  1    perl-5.6.1-26.72.3
D: ========== successors only (presentation order)
D:     4    1    6  1    mod_perl-1.26-2
D:     5    1    4  2      perl-CGI-2.752-26.72.3
D: installing binary packages
D: getting list of mounted filesystems
Preparing...                D: opening  db environment /var/lib/rpm/Basenames 
D: opening  db index       /var/lib/rpm/Basenames create mode=0x42
########################################### [100%]
D: Expected size:        19427 = lead(96)+sigs(293)+pad(3)+data(19035)
D:   Actual size:        19427
D:   install: perl-NDBM_File-1.75-26.72.3 has 5 files, test = 0
Segmentation fault

I've followed the instructions in the rpm-list email from Tom Diehl (dated Mar 
9, 2002) and don't get any errors, but it still doesn't solve my problem

I'm not sure exactly what caused the problem, but it may have been when I tried 
to do a rpm -ba samba from the samba src rpm to get ldap support

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. I don't know what caused this so I can't tell you how to reproduce it

Expected Results:  It should be able to install, upgrade, or delete packages

Additional info:

I tried upgrading to rpm 4.0.4 but I can't through rpm (I get a segmentation 
fault) and trying to compile from source gave me all kinds of compiler errors
Comment 1 Jeff Johnson 2002-03-21 09:45:55 EST
Add a pointer (i.e. URL, attachments won't work) to a tarball of
you database
	cd /var/lib
	tar czvf /tmp/rpmdb-61522.tar.gz rpm
and I'll see if I can get you a fix.
Comment 2 Brian Johnson 2002-03-21 10:34:31 EST
tarball of my database is available at:
Comment 3 Jeff Johnson 2002-03-22 11:32:34 EST
Hmmm, I've gotten myself confused between #61522 and
#61552. Apologies.

Fix in a moment ...
Comment 4 Jeff Johnson 2002-03-22 11:42:25 EST
Hmmm, I don't see a problem with your rpmdb
using rpm-4.0.4.

Just in case, I've rebuilt your rpmdb, tarball
of rpm/Packages at
Download and install by doing
	cd /var/lib
	mv rpm/Packages rpm/Packages-ORIG
	tar xzvf rpmdb-61552-FIX.tar.gz
	rpm --rebuilddb -vv

I'd suggest using rpm-4.0.4.

Hmmm, are you using LDAP passwords? If so,
you need to start up nscd, as there's a
linkage problem deep in PAM modules that
affects statically linked binaries like rpm.

Note You need to log in before you can comment on or make changes to this bug.