Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 615529 - Config file confusion
Config file confusion
Status: CLOSED DUPLICATE of bug 575341
Product: Fedora
Classification: Fedora
Component: tomcat6 (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: David Knox
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-16 18:32 EDT by Orion Poplawski
Modified: 2015-11-01 19:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-23 17:24:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2010-07-16 18:32:03 EDT
Description of problem:

/etc/init.d/tomcat6 sources /etc/sysconfig/tomcat6, then runs /usr/sbin/tomcat6 which sources /etc/tomcat6/tomcat6.conf which is basically the same as /etc/sysconfig/tomcat6 and overwrites those values.

I would suggest making /etc/tomcat6/tomcat6.conf a symlink to /etc/sysconfig/tomcat6 or something similar.

Also, tomcat6 probably should probably create and own /var/run/tomcat6 owned by tomcat and put the pid file there to avoid the file creation shenanigans of the init script.  Helps with systemd too I think.


Version-Release number of selected component (if applicable):
tomcat6-6.0.26-8.fc14.noarch
Comment 1 Bug Zapper 2010-07-30 08:37:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Admin XMLRPC Client 2010-08-23 13:58:39 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 John Dennis 2010-09-23 17:24:17 EDT

*** This bug has been marked as a duplicate of bug 575341 ***

Note You need to log in before you can comment on or make changes to this bug.