Bug 615560 - kernel-2.6.34.<x>.x86_64 doesn't resume
Summary: kernel-2.6.34.<x>.x86_64 doesn't resume
Keywords:
Status: CLOSED DUPLICATE of bug 628897
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-17 05:39 UTC by Rodd Clarkson
Modified: 2010-09-04 07:40 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-04 07:40:50 UTC


Attachments (Terms of Use)
pm-suspend.log (in case it helps) (4.71 KB, application/octet-stream)
2010-07-17 05:39 UTC, Rodd Clarkson
no flags Details

Description Rodd Clarkson 2010-07-17 05:39:32 UTC
Created attachment 432542 [details]
pm-suspend.log (in case it helps)

Description of problem:

When I activate suspend on my laptop, it starts to suspend (it gets at least as far as turning off the network) and then stops.

A hard restart (holding down the power key until it turns off) is required to restart.


lspci output:

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 12)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
02:00.0 VGA compatible controller: ATI Technologies Inc Device 9488
02:00.1 Audio device: ATI Technologies Inc RV710/730
04:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)
07:00.0 SD Host controller: Ricoh Co Ltd Device e822 (rev 01)
07:00.1 System peripheral: Ricoh Co Ltd Device e230 (rev 01)
07:00.2 System peripheral: Ricoh Co Ltd Device e852 (rev 01)
07:00.3 FireWire (IEEE 1394): Ricoh Co Ltd Device e832 (rev 01)
09:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

Comment 1 Joachim Frieben 2010-08-09 08:09:59 UTC
Same issue on a system equipped with an ATI Radeon X800 (R420): kernel 2.6.33.6-147.fc13.x86_64 suspends correctly whereas kernel 2.6.34.2-33.fc13.x86_64 hangs during suspend. The hardware profile can be found at

  http://smolt.fedoraproject.org/show?uuid=pub_923759ad-3a1c-4a07-947f-efcb6f39b40c .

Monitor gets powered off, but system fans keep on running indefinitely.

Comment 2 Joachim Frieben 2010-08-13 15:05:08 UTC
Kernel 2.6.34.4-38.rc1.fc13 also fails.

Comment 3 Stan Trzmiel 2010-08-15 12:33:57 UTC
I'm experiencing exactly the same issue. Most likely it's related to radeon kernel bits.
I've changed board in my Dell D610 from intel gfx one to radeon X300 mobile-equipped one and laptop stopped to suspend/hibernate. It works fine in 2.6.33 kernels.

My smolt profile

http://www.smolts.org/client/show/pub_d9211db6-e2ce-49af-9ae9-b8f2915ac93c

Current kernels:
 - kernel-2.6.33.6-147.fc13.i686
 - kernel-2.6.34.4-38.rc1.fc13.i686

Comment 4 Joachim Frieben 2010-08-15 23:23:50 UTC
It is possible to install kernel 2.6.35.2-8.fc14 on an F13 system. Supend and resume both work for me after this update.

Comment 5 Rodd Clarkson 2010-08-21 06:33:19 UTC
I've just tried kernel-2.6.34.4-42.fc13 and it still fails to suspend.

I haven't tried 2.6.35.2-8.fc14

Comment 6 Rodd Clarkson 2010-09-02 00:57:50 UTC
This is still a problem with kernel-2.6.34.6-47.fc13.x86_64 which was pushed to updates recently.

There are at least three people who have reported this problem (on a testing kernel).

Why wasn't any attempt made to try and find out what going wrong before pushing this to updates.

I've added 99 votes to this bug as it is now a serious bugbear from me regarding having to manually handle future updates.

Comment 7 Rodd Clarkson 2010-09-02 01:03:34 UTC
I think it's worth mentioning that these kernels seem to have a number of other 'issues' but I haven't bothered with too much testing as I needed the kernel to be stable enough to rely on to test them.  Not being able to suspend (and resume) is a show stopper in my opinion.

Other issues I've notices are sound related, and also stuttering while playing media in MythTV.

Comment 8 Chuck Ebbert 2010-09-02 10:26:14 UTC
(In reply to comment #6)
> This is still a problem with kernel-2.6.34.6-47.fc13.x86_64 which was pushed to
> updates recently.
> 
> There are at least three people who have reported this problem (on a testing
> kernel).
> 
> Why wasn't any attempt made to try and find out what going wrong before pushing
> this to updates.
> 

Suspend/resume has always been a problem and it's usually hardware-specific. We have several reports from people whose machines would not suspend/resume with 2.6.33 but everything works on 2.6.34. The same thing happened on switching from 2.6.31 to 2.6.32 in Fedora 12. If we waited until it worked for everyone we would never be able to release any kernel updates, ever.

Comment 9 Adel Gadllah 2010-09-02 10:47:59 UTC
Anyway does 

echo 0 > /sys/power/pm_async (as root)

before suspending solve the issue? (Asynchronous suspend/resume has been merged in .34 and might have issue with some hardware so it might be worth trying).

Comment 10 Rodd Clarkson 2010-09-02 11:46:32 UTC
Just tried this.  No success for me.

Comment 11 Stan Trzmiel 2010-09-02 18:40:52 UTC
kernel-2.6.34.6-49.fc13.i686 from koji solves issue for me

Thanks Dave you're DA MAN, I knew I can count on you :thumbs up:

Comment 12 Rodd Clarkson 2010-09-03 02:19:45 UTC
I've tried kernel-2.6.34.6-49.fc13.i686 and we can now change this bug from fails to suspend to fails to resume.

My system will now suspend, but won't resume.  I have a similar or the same problem with f14's kernels 2.6.35.x I believe.

It's a step forward.

Comment 13 Chuck Ebbert 2010-09-03 12:39:48 UTC
(In reply to comment #12)
> I've tried kernel-2.6.34.6-49.fc13.i686 and we can now change this bug from
> fails to suspend to fails to resume.
> 
> My system will now suspend, but won't resume.  I have a similar or the same
> problem with f14's kernels 2.6.35.x I believe.
> 

If it won't resume, you can try the pm_trace method of trying to figure out which device causes the resume failure.

Comment 14 Joachim Frieben 2010-09-03 18:37:30 UTC
Suspend and resume are working now as expected with kernel 2.6.34.6-49.fc13 for the system specified in comment #5.

Comment 15 Rodd Clarkson 2010-09-04 07:37:41 UTC
(In reply to comment #14)
> Suspend and resume are working now as expected with kernel 2.6.34.6-49.fc13 for
> the system specified in comment #5.

I'm assuming that you are referring to comment #3.

Should I be opening a new bug for my suspend resume issues since technically the suspend issue this bug was about has been addressed.

I'm pretty sure that the issue I'm having is also the same as a bug I've filed for f14 where resume doesn't work.

Comment 16 Rodd Clarkson 2010-09-04 07:40:50 UTC
I've tried the pm_trace method and I just get the some outcome as this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=628897

I suspend that this is the same problem I'm having in both f13 with the 2.6.34 kernels and in f14 with the 2.6.35 kernels.

*** This bug has been marked as a duplicate of bug 628897 ***


Note You need to log in before you can comment on or make changes to this bug.