Bug 615621 - fedora-kde-icon-theme : Inherits=oxygen not working as expected
fedora-kde-icon-theme : Inherits=oxygen not working as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-kde-icon-theme (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: kde-4.5
  Show dependency treegraph
 
Reported: 2010-07-17 10:26 EDT by Rex Dieter
Modified: 2010-11-09 20:16 EST (History)
5 users (show)

See Also:
Fixed In Version: goddard-kde-theme-13.1.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 05:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-07-17 10:26:34 EDT
One test case on fedora-kde-icon-theme
Inherits=oxygen
not working as expected was mentioned on irc yesterday.

When switching between fedora-kde and oxygen icon themes, at least the mimetype icon for .jpg files changes (in dolphin anyway).  For me, it displayed a different icon, the reporter in channel was that fedora-kde ended up with '?' broken icon.

I'm a little stumped how/why this is happening, but haven't investigated fedora-kde's index.theme file thoroughly yet.
Comment 1 Kevin Kofler 2010-07-20 09:01:16 EDT
Maybe a bug in the code that looks up the MIME type icons?
Comment 2 Rex Dieter 2010-09-02 11:17:42 EDT
Now that kickoff (and classic) has a conf option to specific icon , I don't see any much need for keeping fedora-kde-icon-theme around ...

For f14+, any objections to a plan of : 
1.  get rid of fedora-kde-icon-theme
2.  set the aforementioned kickoff option
3.  and use oxygen-icon-theme by default
??
Comment 3 Lukáš Tinkl 2010-09-02 12:46:31 EDT
Dropping fedora-kde-icon-theme seems like a sensible option
Comment 4 Fedora Update System 2010-09-03 11:09:25 EDT
kde-settings-4.5-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kde-settings-4.5-4.fc14
Comment 5 Fedora Update System 2010-09-03 12:42:48 EDT
kde-settings-4.5-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-settings'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kde-settings-4.5-4.fc14
Comment 6 nucleo 2010-09-13 05:44:10 EDT
There is also "?" icon shown in KMix when fedora-kde-icon-theme used.
Switching to oxygen fixes this issue too.
Comment 7 Rex Dieter 2010-09-13 08:33:36 EDT
I cannot reproduce comment #6 , but the point is moot now.
Comment 8 nucleo 2010-09-13 08:45:19 EDT
Steps to reproduce:
1. Start nightly-composes LiveCD (now Fedora-KDE icon theme used there).
2. Open Mixer. "?" icon will be displayed:
http://img255.imageshack.us/img255/5346/snapshot1h.png
3. Change icon theme to Oxygen and restart KDE.
4. Open Mixer again. Normal icon will be there:
http://img718.imageshack.us/img718/6722/snapshot2gi.png
Comment 9 Fedora Update System 2010-09-14 01:08:23 EDT
kde-settings-4.5-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Michal Hlavinka 2010-09-24 01:32:56 EDT
Is there any kde-settings update for F13? I can't see anything in koji/kde/kde-testing/kde-unstable
Comment 11 Rex Dieter 2010-09-24 07:59:13 EDT
For now, this is f14+ only.  This introduces a slight change in behavior, so we'll have to carefully consider whether to backport this for f13 or not.
Comment 12 Kevin Kofler 2010-09-24 09:04:28 EDT
I think dropping the Fedora-KDE theme is not an option for F13, we really need the actual bug fixed.

BTW, this change is also incomplete for F14, we need 2 more things:
1. an update to fedora-logos moving start-here-fedora into Oxygen and
2. a copy of http://bazaar.launchpad.net/~kubuntu-members/kubuntu-default-settings/ubuntu/annotate/head:/share/apps/plasma-desktop/updates/02-kubuntu-menu-icon.js with s/kubuntu/fedora/g.

Right now we're no longer using the Fedora logo as the menu icon, which is what we had that Fedora-KDE theme for in the first place.
Comment 13 Kevin Kofler 2010-09-24 09:08:32 EDT
More precisely, lines 11 to 14 of the update script should probably be changed to:
    if (widget && (widget.type == 'launcher') &&
        widget.readConfig("icon", "start-here") == "start-here") {
        widget.writeConfig("icon", "start-here-fedora");
    } // if launcher
Comment 14 Rex Dieter 2010-09-24 09:43:57 EDT
cool!  much better.
Comment 15 Kevin Kofler 2010-09-24 09:56:02 EDT
BTW, fedora-logos in F13 still uses /usr/share/kde-settings/kde-profile/default/share/icons/Fedora-KDE even though that's no longer where the Fedora-KDE theme itself lives.

As for the update script, I think it will actually need to read:
    if (widget && (widget.type == 'launcher') &&
        (widget.readConfig("icon", "start-here-kde") == "start-here-kde"
         || widget.readConfig("icon", "start-here-kde") == "start-here")) {
        widget.writeConfig("icon", "start-here-fedora");
    } // if launcher
The current default is start-here-kde (which picks up start-here from Fedora-KDE before start-here-kde from the inherited Oxygen due to how inheritance works in KDE 4), but some people may have it set to start-here (which in Fedora-KDE was the same icon).

It should be changed to start-here-fedora by a script, and we should rename and move the icon in fedora-logos.
Comment 16 Rex Dieter 2010-09-28 11:41:16 EDT
we can just use fedora-logo-icon , which fedora-logos already provides.
Comment 17 Rex Dieter 2010-09-28 13:23:39 EDT
decided on using start-here-kde-fedora as that's the safest fallback-wise
Comment 18 Fedora Update System 2010-09-28 14:25:26 EDT
kde-settings-4.5-6.fc14,fedora-logos-14.0.0-2.fc14,generic-logos-14.0.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kde-settings-4.5-6.fc14,fedora-logos-14.0.0-2.fc14,generic-logos-14.0.1-2.fc14
Comment 19 Fedora Update System 2010-09-28 14:52:43 EDT
fedora-logos-13.0.2-2.fc13,generic-logos-13.0.1-2.fc13,kde-settings-4.4-17.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/fedora-logos-13.0.2-2.fc13,generic-logos-13.0.1-2.fc13,kde-settings-4.4-17.fc13
Comment 20 Michal Hlavinka 2010-09-28 17:00:57 EDT
I've just updated fedora-logos and kde-settings* (I don't have generic-logos):
# rpm -qa 'kde-settings*' fedora-logos
fedora-logos-13.0.2-2.fc13.noarch
kde-settings-4.4-17.fc13.noarch
kde-settings-kdm-4.4-17.fc13.noarch
kde-settings-pulseaudio-4.4-17.fc13.noarch

and rebooted computer, but after reboot there are still no icons for jpg and some other file types.

(kde 4.5.1 on F-13)
Comment 21 Michal Hlavinka 2010-09-29 03:43:54 EDT
with kde-settings-4.4-18 there is an improvement

* first machine
- 4.4-17 = no change
- 4.4-18 = fixed for clean profile where fedora start icon is replaced by kde start icon, for old profile there is still fedora start icon and no images for jpg file type

* second machine
- 4.4-17 = fedora start icon is replaced, but no images for jpg files
- 4.4-18 = fixed for clean profile (can't relogin just now, so can't tell if fixed for old profile), fedora start icon in clean profile replaced (old profile not tested yet)
Comment 22 Fedora Update System 2010-09-29 12:57:43 EDT
kde-settings-4.5-6.fc14, fedora-logos-14.0.0-2.fc14, generic-logos-14.0.1-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-settings fedora-logos generic-logos'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kde-settings-4.5-6.fc14,fedora-logos-14.0.0-2.fc14,generic-logos-14.0.1-2.fc14
Comment 23 nucleo 2010-09-30 07:49:51 EDT
There is blank space in tray for SELinux denial on F14 Beta LiveCD after updating kde-settings, fedora-logos and generic-logos.
Don't know is this problem related to this bug.
Comment 24 Rex Dieter 2010-09-30 08:58:49 EDT
re comment #23

that's a separate, independent problem.
Comment 25 Kevin Kofler 2010-10-03 00:10:19 EDT
So we have a few reports that the migration in kde-settings is not working.

First observation: the code has:
if (!w || w.type != "launcher") continue;
but what about the simple menu?

This should probably be:
if (!w || (w.type != "launcher" && w.type != "simplelauncher"))
but we need to verify that the simple menu actually supports this setting.

There might be some other problems, too.
Comment 26 Rex Dieter 2010-10-03 06:39:36 EDT
In my own testing, I tried switching to/from both kickoff and simplemenu, and they both showed the Fedora F, but the account(s) in question were using kickoff initially.
Comment 27 Kevin Kofler 2010-10-08 11:43:09 EDT
Well, at the very least we need to fix the migration script as per comment #25.

I also wonder if all the people who reported the script not working are using the simple menu or if there's some other source of breakage.
Comment 28 Kevin Kofler 2010-10-08 11:45:34 EDT
(And yes, I'm sure the change from comment #25 is needed, otherwise the script will not find the simplelauncher at all when doing its job, so it has no chance of working.)
Comment 29 Fedora Update System 2010-10-09 22:04:08 EDT
kde-settings-4.5-8.fc14, fedora-logos-14.0.0-2.fc14, generic-logos-14.0.1-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-settings fedora-logos generic-logos'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kde-settings-4.5-8.fc14,fedora-logos-14.0.0-2.fc14,generic-logos-14.0.1-2.fc14
Comment 30 Fedora Update System 2010-10-14 12:46:16 EDT
goddard-kde-theme-13.1.0-1.fc14,kde-settings-4.5-9.fc14,laughlin-kde-theme-14.0.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/goddard-kde-theme-13.1.0-1.fc14,kde-settings-4.5-9.fc14,laughlin-kde-theme-14.0.0-1.fc14
Comment 31 Fedora Update System 2010-10-19 05:10:12 EDT
goddard-kde-theme-13.1.0-1.fc14, kde-settings-4.5-9.fc14, laughlin-kde-theme-14.0.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2010-11-09 20:16:36 EST
fedora-logos-13.0.2-2.fc13, generic-logos-13.0.1-2.fc13, goddard-kde-theme-13.1.0-1.fc13, kde-settings-4.4-21.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.