Bug 615653 - [abrt] crash in ibus-1.3.6-1.fc13: raise: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] crash in ibus-1.3.6-1.fc13: raise: Process /usr/bin/ibus-daemon was ki...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
abrt_hash:1db965d8e70f83e0d09bedd3fd1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-17 15:04 EDT by cyrushmh
Modified: 2010-07-28 00:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 00:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (22.27 KB, text/plain)
2010-07-17 15:04 EDT, cyrushmh
no flags Details

  None (edit)
Description cyrushmh 2010-07-17 15:04:47 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/ibus-daemon --xim
component: ibus
crash_function: raise
executable: /usr/bin/ibus-daemon
global_uuid: 1db965d8e70f83e0d09bedd3fd150286838c0896
kernel: 2.6.33.6-147.fc13.i686.PAE
package: ibus-1.3.6-1.fc13
rating: 4
reason: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)
Comment 1 cyrushmh 2010-07-17 15:04:51 EDT
Created attachment 432622 [details]
File: backtrace
Comment 2 fujiwara 2010-07-19 23:45:33 EDT
Would you give how to reproduce the bug?
I don't see any segv.

From your backtrace, g_free(ibus->global_previous_engine_name) is failed.

I created an patch but not sure if it can fix your problem.
http://github.com/fujiwarat/ibus/commit/2f9a099f9604ead1d783548c59feb44698c1f501
Comment 3 cyrushmh 2010-07-20 02:37:33 EDT
我安装了(I install ) yum install ibus-pinyin*(no debuginfo) ibus-qt ibus-gtk 这些套件(these packages ),
我不知道为什么(I don't know why ),经常这样(always have this abrt bug),
一般遇到crash的情况,(注意这不是步骤)
1、一般在使用flash网页,或者在打字的时候突然crash,
2、还有就是,当firefox打开超过20个网站/网页时,在某个站点/网页打字的时候也会这样,
3、最后,我认为是我安装了xguest[yum install xguest]以及有时使用xguest帐户时出现
Comment 4 fujiwara 2010-07-20 05:12:55 EDT
(In reply to comment #3)
> 3、最后,我认为是我安装了xguest[yum install xguest]以及有时使用xguest帐户时出现    

Do you mean to enable SELINUX?
IBus works without SELINUX?
My understanding is, xguest acount is not used if SELINUX is disabled.
Comment 5 cyrushmh 2010-07-20 23:57:39 EDT
(In reply to comment #4)
> Do you mean to enable SELINUX?
I enable from f9 to f13(now), never disable.
> IBus works without SELINUX?
I don't know ,sorry 
> My understanding is, xguest acount is not used if SELINUX is disabled.    
then close this 疑点
Comment 6 fujiwara 2010-07-22 04:51:22 EDT
OK, when I run ibus with xguest, I got the following error in Fedora 13.

% python /usr/share/ibus/ui/gtk/main.py
Traceback (most recent call last):
  File "/usr/share/ibus/ui/gtk/main.py", line 33, in <module>
    import ibus
  File "/usr/lib/python2.6/site-packages/ibus/__init__.py", line 26, in <module>
    from common import *
  File "/usr/lib/python2.6/site-packages/ibus/common.py", line 55, in <module>
    import ctypes
  File "/usr/lib64/python2.6/ctypes/__init__.py", line 546, in <module>
    CFUNCTYPE(c_int)(lambda: None)
MemoryError


It seems SELINUX doesn't enable /var/tmp and python ctypes module doesn't work. bug 582009

After I run setsebool command, I could run ibus .

% su -
# setsebool -P allow_xguest_exec_content 1

% /usr/bin/ibus-daemon --xim &

How about setsebool command for you?
My error log is different from yours but I could run ibus and firefox without no problems.
Probably I guess most selinux issues are necessary permissions are lost and /var/log/messages could explain your errors.
Comment 7 cyrushmh 2010-07-22 06:28:18 EDT
(In reply to comment #6)

>How about setsebool command for you?
no I never use this command (我没有用这个命令,或者说我不懂这个)

>My error log is different from yours but I could run ibus and firefox without
no problems.
the error log same (跟你所展示的错误一样)
about ibus & firefox question :when firefox open above 20 website,and use ibus-pinyin type at flash's website
>Probably I guess most selinux issues are necessary permissions are lost and
>/var/log/messages could explain your errors.    

the error log same (跟你所展示的错误一样)
Comment 8 cyrushmh 2010-07-22 06:35:09 EDT
oh ,sorry ,I forgot,
and sandbox also can not use ibus-pinyin,
yum install policycoreutils-sandbox

$sandbox -X -t sandbox_web_t firefox (or type website follow)
Comment 9 fujiwara 2010-07-23 06:10:17 EDT
(In reply to comment #7)
> (In reply to comment #6)
> 
> >How about setsebool command for you?
> no I never use this command (我没有用这个命令,或者说我不懂这个)

But if I don't run this command, I could not run ibus-daemon in f13 selinux.
If ibus icon is not shown in your gnome-panel icon status, I guess you need to run the command.

> 
> >My error log is different from yours but I could run ibus and firefox without
> no problems.
> the error log same (跟你所展示的错误一样)
> about ibus & firefox question :when firefox open above 20 website,and use
> ibus-pinyin type at flash's website

Would you provide the flash page?
Also I wonder which 32bit or 64bit Fedora you run.
It seems currently 64bit flash plugin is stopped:
http://labs.adobe.com/technologies/flashplayer10/64bit.html

So if you use 64bit Fedora, probably you need to choose 32 bit wrapped version:
http://fedoraproject.org/wiki/Flash

But in my test, the flash 32bit wrapper doesn't enable IBus correctly. But I don't see any SEGV.
NOTE: flash version 10 doesn't work with IBus. flash version 10.1 is required.

Probably you could check if your firefox is 32bit or 64bit:

# rpm -q firefox
firefox-3.6.4-1.fc13.x86_64

After you run firefox, "about:plugins" URI shows which libflashplayer.so is used.

(In reply to comment #8)
> yum install policycoreutils-sandbox
> 
> $sandbox -X -t sandbox_web_t firefox (or type website follow)    

I think it's a different issue. Probably some configurations are missed in selinux but I guess it's not a IBus specific issue.

Since I cannot reproduce your problem, maybe it's better to provide the test binary if the following patch can fix your problem.
> http://github.com/fujiwarat/ibus/commit/2f9a099f9604ead1d783548c59feb44698c1f501
Comment 10 cyrushmh 2010-07-23 22:40:25 EDT
(In reply to comment #9)

>But if I don't run this command, I could not run ibus-daemon in f13 selinux.
If ibus icon is not shown in your gnome-panel icon status, I guess you need to
run the command.
I would try

>Would you provide the flash page?
yes, when use ibus-pinyin type at flash page

>Also I wonder which 32bit or 64bit Fedora you run.
32bit(use fedora 13_i686 ) , I use adobe flash-plugin with adobe-yum with 32bit(when I use this before ,I use free flash-plugin but the free or gnu flash-plugin don't support type chinese now.)

>It seems currently 64bit flash plugin is stopped:
>http://labs.adobe.com/technologies/flashplayer10/64bit.html
>So if you use 64bit Fedora, probably you need to choose 32 bit wrapped version:
http://fedoraproject.org/wiki/Flash
I know, I see about this nesw
But in my test, the flash 32bit wrapper doesn't enable IBus correctly. But I
don't see any SEGV.
NOTE: flash version 10 doesn't work with IBus. flash version 10.1 is required.

Probably you could check if your firefox is 32bit or 64bit:

# rpm -q firefox
firefox-3.6.4-1.fc13.x86_64

After you run firefox, "about:plugins" URI shows which libflashplayer.so is
used.

(In reply to comment #8)
> yum install policycoreutils-sandbox
> 
> $sandbox -X -t sandbox_web_t firefox (or type website follow)    

I think it's a different issue. Probably some configurations are missed in
selinux but I guess it's not a IBus specific issue.

Since I cannot reproduce your problem, maybe it's better to provide the test
binary if the following patch can fix your problem.
> http://github.com/fujiwarat/ibus/commit/2f9a099f9604ead1d783548c59feb44698c1f501    

额~~I'm lazy to install only with rpm
Comment 11 fujiwara 2010-07-26 02:04:50 EDT
I created the test binary which includes the patch only.
> http://github.com/fujiwarat/ibus/commit/2f9a099f9604ead1d783548c59feb44698c1f501
http://fujiwara.fedorapeople.org/ibus/20100726/2350610/ibus-1.3.6-2.fc13.i686.rpm

Would you test this rpm if your problem can be fixed?


(In reply to comment #10)
> >Would you provide the flash page?
> yes, when use ibus-pinyin type at flash page

Sorry, would you provide the actual flash URL which you encountered your problem with, in case your problem is not fixed with above rpm?
I tried some flash pages but I don't see any problems.

> 32bit(use fedora 13_i686 ) , I use adobe flash-plugin with adobe-yum with
> 32bit(when I use this before ,I use free flash-plugin but the free or gnu
> flash-plugin don't support type chinese now.)

OK, I understood you use 32bit.
Comment 12 cyrushmh 2010-07-26 06:33:55 EDT
(In reply to comment #11)
> I created the test binary which includes the patch only.
> > http://github.com/fujiwarat/ibus/commit/2f9a099f9604ead1d783548c59feb44698c1f501
> http://fujiwara.fedorapeople.org/ibus/20100726/2350610/ibus-1.3.6-2.fc13.i686.rpm
> 
> Would you test this rpm if your problem can be fixed?
> 

no, I always stable yum to update, 
> 
> (In reply to comment #10)
> > >Would you provide the flash page?
> > yes, when use ibus-pinyin type at flash page
> 
> Sorry, would you provide the actual flash URL which you encountered your
> problem with, in case your problem is not fixed with above rpm?
> I tried some flash pages but I don't see any problems.
> 

but, this chinese web flashgame ,  I'm tried to give info too.
" xiaoi.com "<<<web-flash-game,and you could talk at small windows chat
Comment 13 fujiwara 2010-07-27 23:15:45 EDT
(In reply to comment #12)
> > http://fujiwara.fedorapeople.org/ibus/20100726/2350610/ibus-1.3.6-2.fc13.i686.rpm
> no, I always stable yum to update, 

Fixes can be integrated into stable yum if the fixes are verified.
If none verifies the fix, the unstable fix won't be available in stable yum.

Since I cannot reproduce your problem, if you won't test the rpm, I'd like this might be closed as a invalid bug at the moment until another valid bug will be filed by other people.

> but, this chinese web flashgame ,  I'm tried to give info too.
> " xiaoi.com "<<<web-flash-game,and you could talk at small windows chat    

Hmm.., the xiaoi.com is difficult for me.
I tried to login with a new account and looked at a chat window with Chinese-English dictionary.
I typed some Chinese characters but I don't see any problems.
After I logged out, I no longer can login. It seems the Chinese shows 'account or password is invalid' but the new account and password are same. Maybe it might reject the login without Microsoft Network account.

Can you provide another URL?

It's difficult for me which is free game or pay games and which links can start flash text.

I'll ask other Chinese people.
Comment 14 fujiwara 2010-07-27 23:30:50 EDT
Generally I use the following URL to test flash text
http://www.ustream.tv/channel/CBS-News
And flash text works fine with me.

Note You need to log in before you can comment on or make changes to this bug.