Bug 615699 - [abrt] crash in gnome-applet-alarm-clock-0.3.1-1.fc12: raise: Process /usr/bin/alarm-clock-applet was killed by signal 6 (SIGABRT)
[abrt] crash in gnome-applet-alarm-clock-0.3.1-1.fc12: raise: Process /usr/bi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-applet-alarm-clock (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:56c5c6b2a18bcab58c465dbef48...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-17 23:57 EDT by chanueting
Modified: 2010-10-08 16:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: gnome-applet-alarm-clock-0.3.1-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 21:27:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.81 KB, text/plain)
2010-07-17 23:57 EDT, chanueting
no flags Details
alarm-clock-applet dump that I run the applet in command line (1.08 KB, text/plain)
2010-07-17 23:59 EDT, chanueting
no flags Details
Recent dump shows that the autostart successfully (2.05 KB, text/plain)
2010-07-31 04:18 EDT, chanueting
no flags Details
Dump of failing to have autostart enabled (14.93 KB, application/octet-stream)
2010-08-01 00:22 EDT, chanueting
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 610632 None None None Never

  None (edit)
Description chanueting 2010-07-17 23:57:24 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: alarm-clock-applet
comment: Produce every time that I do it.
component: gnome-applet-alarm-clock
crash_function: raise
executable: /usr/bin/alarm-clock-applet
global_uuid: 56c5c6b2a18bcab58c465dbef4803dcc98c5d39b
kernel: 2.6.32.16-141.fc12.i686.PAE
package: gnome-applet-alarm-clock-0.3.1-1.fc12
rating: 4
reason: Process /usr/bin/alarm-clock-applet was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.Open the applet
2.Right click the applet then select Preference
3.Check the box of "Start automatically at login"
Comment 1 chanueting 2010-07-17 23:57:27 EDT
Created attachment 432658 [details]
File: backtrace
Comment 2 chanueting 2010-07-17 23:59:38 EDT
Created attachment 432659 [details]
alarm-clock-applet dump that I run the applet in command line

And here is a dump that I got running the applet in command line with the same actions as above.
Comment 3 Christoph Wickert 2010-07-27 18:31:30 EDT
Thanks for your bug report. I forwarded it to the developer of the program at https://bugs.launchpad.net/fedora/+bug/610632

If you have a launchpad account, you can also subscribe to that bug in get notified about any updates. Otherwise I will get back to you when I have more questions or the bug is resolved.
Comment 4 Christoph Wickert 2010-07-27 18:40:13 EDT
Sorry, but I do have one question: is /usr/share/applications/alarm-clock-applet.desktop in place and readable? On my system the file is available and alarm-clock does not crash.
Comment 5 chanueting 2010-07-31 04:18:29 EDT
Created attachment 435736 [details]
Recent dump shows that the autostart successfully

May be the recent packages update solved this bug, I cannot reproduce it anymore.
Comment 6 Christoph Wickert 2010-07-31 12:14:15 EDT
I don't think it's really fixed, but now ~/.config/autostart exists. Can you please test somthing for me?

1. Disable the autostart in gnome-applet-alarm-clock
2. mv cd ~/.config/autostart ~/.config/autostart.back
3. Enable autostart in gnome-applet-alarm-clock. I guess it' going to crash now.
4. Is there ~/.config/autostart now and is the a launcher for alarm-clock inside?
5. After the tests, move ~/.config/autostart.back to ~/.config/autostart

Thanks!
Comment 7 chanueting 2010-08-01 00:22:41 EDT
Created attachment 435826 [details]
Dump of failing to have autostart enabled

I am afraid you are right, and here is a dump in command-line showing the result. However, I have no idea to get the crash report from abrt. Could you mind showing me a way if you think the abrt report is helpful as well.
Comment 8 Fedora Update System 2010-09-27 18:09:52 EDT
gnome-applet-alarm-clock-0.3.1-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnome-applet-alarm-clock-0.3.1-2.fc13
Comment 9 Fedora Update System 2010-09-27 18:09:55 EDT
gnome-applet-alarm-clock-0.3.1-2.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/gnome-applet-alarm-clock-0.3.1-2.fc12
Comment 10 Fedora Update System 2010-09-27 18:11:05 EDT
gnome-applet-alarm-clock-0.3.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnome-applet-alarm-clock-0.3.1-2.fc14
Comment 11 Fedora Update System 2010-09-28 01:27:56 EDT
gnome-applet-alarm-clock-0.3.1-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-applet-alarm-clock'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnome-applet-alarm-clock-0.3.1-2.fc13
Comment 12 Fedora Update System 2010-10-05 21:27:17 EDT
gnome-applet-alarm-clock-0.3.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-10-08 16:34:30 EDT
gnome-applet-alarm-clock-0.3.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-10-08 16:36:15 EDT
gnome-applet-alarm-clock-0.3.1-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.