Bug 615733 - [vdsm] vdsm fails to start if no space left on device but alerts nothing about it
Summary: [vdsm] vdsm fails to start if no space left on device but alerts nothing abou...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Dan Kenigsberg
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-18 10:41 UTC by Haim
Modified: 2016-04-18 06:33 UTC (History)
6 users (show)

Fixed In Version: vdsm-4.9-13.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-19 15:15:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Haim 2010-07-18 10:41:57 UTC
Description of problem:

vdsm service fails to start (reasonable) when no space left on disk, however, it alerts nothing about it, and when i start service, it says 'ok', however, whet querying for service status it appears down. 
the problem is that no space left on disk, hence, I suggest to add a test to service when it starts. 

this issue found on rhel6, however, i suppose it exists in previous versions. 

this is important, as when it occurs, log cannot be written, so, no actual info why service doesn't start. 

vdsm 4.9-9-10. 

repro: 

make sure no space left on root partition, and start vdsm

Comment 2 Haim 2010-08-22 06:53:59 UTC
verified, tried to start vdsm service with no success, and got the following message: low space [FAILED]


root@silver-vdse ~]# service vdsmd status
VDS daemon is not running
[root@silver-vdse ~]# service vdsmd start
Starting netconsole...
Server address not specified in /etc/sysconfig/netconsole
Starting iscsid: 
vdsm: low log space                                        [FAILED]

2.6.32-63.el6.x86_64
libvirt-0.8.1-25.el6.x86_64
vdsm-4.9-13.el6.x86_64
device-mapper-multipath-0.4.9-25.el6.x86_64
lvm2-2.02.72-7.el6.x86_64
qemu-kvm-0.12.1.2-2.109.el6.x86_64


Note You need to log in before you can comment on or make changes to this bug.