Bug 61574 - RHEA-2002:024-23 install error
RHEA-2002:024-23 install error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-21 13:54 EST by Gene Czarcinski
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 17:09:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-03-21 13:54:00 EST
This was done on a 7.2 plus all errata system.

Whoever put the big rpm update together did not do proper testing!  This set 
of updates CANNOT be installed with freshen (rpm -Fvh) as the announcements 
says.

Somewhere along the way (for good reasons I assume) the file 
/usr/lib/python1.5/site-packages/poptmodule.so was moved from the rpm-python 
package into its own package (python-popt).  With up2date installed (I had 
previously updated up2date with RHBA-2002:044-12, the freshen (my prefered 
procedure) is no possible.

The only way I could update was to issue rpm -Uvh.

This should really be against "python-popt" component since that is the source
package but that component does not currently exist.
Comment 1 Mike Fleetwood 2002-03-25 17:09:04 EST
Dito.  I get the same problem.  Here is the output from:
rpm -Fvh popt* rpm* python-popt* gnorpm* kdeadmin* rpm2html* rpmfind*
    error: failed dependencies:
            poptmodule.so is needed by up2date-2.7.46-7.x.2
Comment 2 Jeff Johnson 2002-03-27 14:41:19 EST
Install the python-popt package.

FWIW, this isn't an rpm problem.

Note You need to log in before you can comment on or make changes to this bug.